# CVE-2017-12161: Moderate severity vulnerability that affects org.keycloak:keycloak-core

> Attackers can spoof URLs via hosts file to craft malicious password reset requests, potentially gaining valid tokens and compromising accounts.

- **Severity:** High 8.8 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 21 Feb 2018
- **Updated:** 5 Aug 2024
- **Also known as:** CVE-2017-1000500, GHSA-959q-32g8-vvp7

## What is CVE-2017-12161?

CVE-2017-12161 is a high-severity vulnerability in Red Hat, Inc. Keycloak, published on 21 Feb 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

It was found that keycloak before 3.4.2 final would permit misuse of a client-side /etc/hosts entry to spoof a URL in a password reset request. An attacker could use this flaw to craft a malicious password reset request and gain a valid reset token, leading to information disclosure or further attacks.

Weakness: CWE-640 (Weak Password Recovery Mechanism for Forgotten Password), CWE-602 (Client-Side Enforcement of Server-Side Security)

## Which versions are affected by CVE-2017-12161?

2 open source packages ship an affected version, including org.keycloak:keycloak-core. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.keycloak:keycloak-core` | Maven | All versions | 3.4.2 |
| `org.keycloak:keycloak-core` | Maven | All versions | 3.4.2 |

Products: Keycloak Keycloak.

## How do I fix CVE-2017-12161?

Upgrade org.keycloak:keycloak-core to 3.4.2 or later.

## Is CVE-2017-12161 being exploited?

There is no known exploitation of CVE-2017-12161 in the wild and no public exploit code.

## Other vulnerabilities in Red Hat, Inc. Keycloak

- [CVE-2014-3709](https://insights.sbomify.com/CVE-2014-3709/): JBoss Keycloak CSRF Vulnerability (high 8.8)
- [CVE-2014-3651](https://insights.sbomify.com/CVE-2014-3651/): Keycloak vulnerable to uncontrolled resource consumption (high 7.5)
- [CVE-2017-12159](https://insights.sbomify.com/CVE-2017-12159/): Keycloak CSRF Vulnerability (high 7.5)
- [CVE-2017-12158](https://insights.sbomify.com/CVE-2017-12158/): Keycloak Reflected XSS (medium 5.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-12161 and fix it if it is affected.

What it is: CVE-2017-12161 is a high-severity vulnerability in Red Hat, Inc. Keycloak, published on 21 Feb 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2017-12161 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.keycloak:keycloak-core (Maven): affected all versions; fixed in 3.4.2
- org.keycloak:keycloak-core (Maven): affected all versions; fixed in 3.4.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-12161/ (Markdown: https://insights.sbomify.com/CVE-2017-12161/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-12161
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-12161
- OSV: https://osv.dev/vulnerability/CVE-2017-12161

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-12161/
Summaries are generated and may contain mistakes; the official description above is the record.
