# CVE-2017-12165: Undertow Request Smuggling vulnerability

> Attackers can exploit unusual whitespace in HTTP headers to perform request smuggling, bypassing security controls in Undertow.

- **Severity:** Low 2.6 (`CVSS:3.0/AV:N/AC:H/PR:L/UI:R/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 27 Jul 2018
- **Updated:** 5 Aug 2024
- **Also known as:** DEBIAN-CVE-2017-12165, GHSA-5gg7-5wv8-4gcj, UBUNTU-CVE-2017-12165

## What is CVE-2017-12165?

CVE-2017-12165 is a low-severity vulnerability in Redhat Jboss Enterprise Application Platform, published on 27 Jul 2018. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

It was discovered that Undertow before 1.4.17, 1.3.31 and 2.0.0 processes http request headers with unusual whitespaces which can cause possible http request smuggling.

Weakness: CWE-444 (Inconsistent Interpretation of HTTP Requests)

## Which versions are affected by CVE-2017-12165?

6 open source packages ship an affected version, including io.undertow:undertow-core. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `io.undertow:undertow-core` | Maven | All versions | 1.3.31 |
| `io.undertow:undertow-core` | Maven | All versions | 1.3.31 |
| `io.undertow:undertow-core` | Maven | From 1.4.0 | 1.4.17 |
| `io.undertow:undertow-core` | Maven | From 1.4.0 | 1.4.17 |
| `io.undertow:undertow-core` | Maven | From 2.0.0.Alpha1 | 2.0.0.Beta1 |
| `io.undertow:undertow-core` | Maven | From 2.0.0.Alpha1 | 2.0.0.Beta1 |

Products: Redhat Jboss Enterprise Application Platform, Redhat Undertow.

## How do I fix CVE-2017-12165?

Upgrade io.undertow:undertow-core to a fixed version for your release line: 1.3.31, 1.4.17 or 2.0.0.Beta1.

## Is CVE-2017-12165 being exploited?

There is no known exploitation of CVE-2017-12165 in the wild and no public exploit code.

## Other vulnerabilities in Redhat Jboss Enterprise Application Platform

- [CVE-2017-12149](https://insights.sbomify.com/CVE-2017-12149/): Red Hat JBoss Application Server Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2010-1428](https://insights.sbomify.com/CVE-2010-1428/): Red Hat JBoss Information Disclosure (medium 5.9, exploited in the wild)
- [CVE-2010-0738](https://insights.sbomify.com/CVE-2010-0738/): Red Hat JBoss Authentication Bypass (low 3.7, exploited in the wild)
- [CVE-2016-3690](https://insights.sbomify.com/CVE-2016-3690/): Deserialization in n/a (critical 9.8)
- [CVE-2017-7504](https://insights.sbomify.com/CVE-2017-7504/): Deserialization in JBoss (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-12165 and fix it if it is affected.

What it is: CVE-2017-12165 is a low-severity vulnerability in Redhat Jboss Enterprise Application Platform, published on 27 Jul 2018. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2017-12165 in the wild and no public exploit code.

Affected packages and fixed versions:
- io.undertow:undertow-core (Maven): affected all versions; fixed in 1.3.31
- io.undertow:undertow-core (Maven): affected all versions; fixed in 1.3.31
- io.undertow:undertow-core (Maven): affected from 1.4.0; fixed in 1.4.17
- io.undertow:undertow-core (Maven): affected from 1.4.0; fixed in 1.4.17
- io.undertow:undertow-core (Maven): affected from 2.0.0.Alpha1; fixed in 2.0.0.Beta1
- io.undertow:undertow-core (Maven): affected from 2.0.0.Alpha1; fixed in 2.0.0.Beta1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-12165/ (Markdown: https://insights.sbomify.com/CVE-2017-12165/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-12165
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-12165
- OSV: https://osv.dev/vulnerability/CVE-2017-12165

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-12165/
Summaries are generated and may contain mistakes; the official description above is the record.
