{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2017-12194 in the wild and no public exploit code.","fix":"Apply the vendor's patch.","what":"CVE-2017-12194 is a critical memory corruption vulnerability in freedesktop.org spice-gtk, published on 14 Mar 2018. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2017-12194 and fix it if it is affected.\n\nWhat it is: CVE-2017-12194 is a critical memory corruption vulnerability in freedesktop.org spice-gtk, published on 14 Mar 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2017-12194 in the wild and no public exploit code.\n\nAffected product: freedesktop.org spice-gtk. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2017-12194/ (Markdown: https://insights.sbomify.com/CVE-2017-12194/index.md)","id":"CVE-2017-12194","markdown":"https://insights.sbomify.com/CVE-2017-12194/index.md","name":"CVE-2017-12194","record":{"aliases":["DEBIAN-CVE-2017-12194","GHSA-r5rv-8pm6-w5ch","SUSE-SU-2018:0877-1","UBUNTU-CVE-2017-12194","USN-3659-1"],"analysis":{"component_type":"desktop_application","fix_type":"patch","impacts":["code_execution","denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"SPICE client library","requires_auth":"none","summary":"A malicious SPICE server can crash the client or execute arbitrary code via improper message processing in spice-gtk.","user_interaction":"not_required","vuln_class":"memory_corruption"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"spice-gtk","vendor":"spice-gtk_project"}],"cvss":{"score":9.8,"severity":"critical","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.0"},"cwes":[{"id":"CWE-20","name":"Improper Input Validation"},{"id":"CWE-121","name":"Stack-based Buffer Overflow"}],"description":"A flaw was found in the way spice-client processed certain messages sent from the server. An attacker, having control of malicious spice-server, could use this flaw to crash the client or execute arbitrary code with permissions of the user running the client. spice-gtk versions through 0.34 are believed to be vulnerable.","ecosystems":["SUSE:Linux Enterprise Desktop 12 SP3","SUSE:Linux Enterprise Server 12 SP3","SUSE:Linux Enterprise Server for SAP Applications 12 SP3","SUSE:Linux Enterprise Software Development Kit 12 SP3"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Memory corruption in spice-gtk","id":"CVE-2017-12194","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"memory_corruption","year":"2017"},"n_packages":4,"n_references":4,"next":{"headline":"Auth bypass in OpenShift","id":"CVE-2017-12195"},"packages":[{"ecosystem":"SUSE:Linux Enterprise Desktop 12 SP3","fixed":["0.33-3.3.2"],"introduced":["0"],"last_affected":[],"package":"spice-gtk","purl":"pkg:rpm/suse/spice-gtk\u0026distro=SUSE%20Linux%20Enterprise%20Desktop%2012%20SP3","source":"SUSE-SU-2018:0877-1"},{"ecosystem":"SUSE:Linux Enterprise Server 12 SP3","fixed":["0.33-3.3.2"],"introduced":["0"],"last_affected":[],"package":"spice-gtk","purl":"pkg:rpm/suse/spice-gtk\u0026distro=SUSE%20Linux%20Enterprise%20Server%2012%20SP3","source":"SUSE-SU-2018:0877-1"},{"ecosystem":"SUSE:Linux Enterprise Server for SAP Applications 12 SP3","fixed":["0.33-3.3.2"],"introduced":["0"],"last_affected":[],"package":"spice-gtk","purl":"pkg:rpm/suse/spice-gtk\u0026distro=SUSE%20Linux%20Enterprise%20Server%20for%20SAP%20Applications%2012%20SP3","source":"SUSE-SU-2018:0877-1"},{"ecosystem":"SUSE:Linux Enterprise Software Development Kit 12 SP3","fixed":["0.33-3.3.2"],"introduced":["0"],"last_affected":[],"package":"spice-gtk","purl":"pkg:rpm/suse/spice-gtk\u0026distro=SUSE%20Linux%20Enterprise%20Software%20Development%20Kit%2012%20SP3","source":"SUSE-SU-2018:0877-1"}],"prev":{"headline":"Null dereference in Linux kernel since 3.13 up to 4.14 (not including)","id":"CVE-2017-12193"},"products":["spice-gtk"],"published":"2018-03-14","related":[{"cvss_score":6.5,"headline":"Information disclosure in n/a","id":"CVE-2016-3066","kev_date_added":null,"published":"2017-06-06"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"SUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["freedesktop.org"]},"summary":"A malicious SPICE server can crash the client or execute arbitrary code via improper message processing in spice-gtk.","url":"https://insights.sbomify.com/CVE-2017-12194/"}