CVE-2017-12196 Incorrect Authorization in Undertow

Medium 4.8 Published Updated

Attackers can bypass Digest authentication checks by mismatching URIs, allowing unauthorized access to server content via MITM attacks.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2017-12196?

CVE-2017-12196 is a medium-severity authentication bypass vulnerability in Redhat Jboss Enterprise Application Platform, published on 18 Apr 2018. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

Official description

undertow before versions 1.4.18.SP1, 2.0.2.Final, 1.4.24.Final was found vulnerable when using Digest authentication, the server does not ensure that the value of URI in the Authorization header matches the URI in HTTP request line. This allows the attacker to cause a MITM attack and access the desired content on the server.

Weakness: CWE-863, CWE-287

Which versions are affected by CVE-2017-12196?

4 open source packages ship an affected version, including io.undertow:undertow-core. It affects 4 products.

PackageAffectedFixed in
io.undertow:undertow-core MavenAll versions1.4.24.Final
io.undertow:undertow-core MavenAll versions1.4.24.Final
io.undertow:undertow-core MavenFrom 2.0.0.Alpha12.0.2.FInal
io.undertow:undertow-core MavenFrom 2.0.0.Alpha12.0.2.FInal

Products include Redhat Jboss Enterprise Application Platform, Redhat Jboss Fuse, Redhat Undertow, Redhat Virtualization.

How do I fix CVE-2017-12196?

Upgrade io.undertow:undertow-core to a fixed version for your release line: 1.4.24.Final or 2.0.2.FInal.

Upgrade, and rotate credentials and sessions that may have been exposed. More about Authentication bypass.

Is CVE-2017-12196 being exploited?

There is no known exploitation of CVE-2017-12196 in the wild and no public exploit code.

All Redhat Jboss Enterprise Application Platform vulnerabilities

Sources

Also known as DEBIAN-CVE-2017-12196, GHSA-cp7v-vmv7-6x2q, UBUNTU-CVE-2017-12196.

Is CVE-2017-12196 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free