# CVE-2017-12196: Incorrect Authorization in Undertow

> Attackers can bypass Digest authentication checks by mismatching URIs, allowing unauthorized access to server content via MITM attacks.

- **Severity:** Medium 4.8 (`CVSS:3.0/AV:N/AC:H/PR:L/UI:R/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 18 Apr 2018
- **Updated:** 5 Aug 2024
- **Also known as:** DEBIAN-CVE-2017-12196, GHSA-cp7v-vmv7-6x2q, UBUNTU-CVE-2017-12196

## What is CVE-2017-12196?

CVE-2017-12196 is a medium-severity authentication bypass vulnerability in Redhat Jboss Enterprise Application Platform, published on 18 Apr 2018. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

undertow before versions 1.4.18.SP1, 2.0.2.Final, 1.4.24.Final was found vulnerable when using Digest authentication, the server does not ensure that the value of URI in the Authorization header matches the URI in HTTP request line. This allows the attacker to cause a MITM attack and access the desired content on the server.

Weakness: CWE-863 (Incorrect Authorization), CWE-287 (Improper Authentication)

## Which versions are affected by CVE-2017-12196?

4 open source packages ship an affected version, including io.undertow:undertow-core. It affects 4 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `io.undertow:undertow-core` | Maven | All versions | 1.4.24.Final |
| `io.undertow:undertow-core` | Maven | All versions | 1.4.24.Final |
| `io.undertow:undertow-core` | Maven | From 2.0.0.Alpha1 | 2.0.2.FInal |
| `io.undertow:undertow-core` | Maven | From 2.0.0.Alpha1 | 2.0.2.FInal |

Products: Redhat Jboss Enterprise Application Platform, Redhat Jboss Fuse, Redhat Undertow, Redhat Virtualization.

## How do I fix CVE-2017-12196?

Upgrade io.undertow:undertow-core to a fixed version for your release line: 1.4.24.Final or 2.0.2.FInal.

## Is CVE-2017-12196 being exploited?

There is no known exploitation of CVE-2017-12196 in the wild and no public exploit code.

## Other vulnerabilities in Redhat Jboss Enterprise Application Platform

- [CVE-2017-12149](https://insights.sbomify.com/CVE-2017-12149/): Red Hat JBoss Application Server Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2010-1428](https://insights.sbomify.com/CVE-2010-1428/): Red Hat JBoss Information Disclosure (medium 5.9, exploited in the wild)
- [CVE-2010-0738](https://insights.sbomify.com/CVE-2010-0738/): Red Hat JBoss Authentication Bypass (low 3.7, exploited in the wild)
- [CVE-2016-3690](https://insights.sbomify.com/CVE-2016-3690/): Deserialization in n/a (critical 9.8)
- [CVE-2017-7504](https://insights.sbomify.com/CVE-2017-7504/): Deserialization in JBoss (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-12196 and fix it if it is affected.

What it is: CVE-2017-12196 is a medium-severity authentication bypass vulnerability in Redhat Jboss Enterprise Application Platform, published on 18 Apr 2018. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2017-12196 in the wild and no public exploit code.

Affected packages and fixed versions:
- io.undertow:undertow-core (Maven): affected all versions; fixed in 1.4.24.Final
- io.undertow:undertow-core (Maven): affected all versions; fixed in 1.4.24.Final
- io.undertow:undertow-core (Maven): affected from 2.0.0.Alpha1; fixed in 2.0.2.FInal
- io.undertow:undertow-core (Maven): affected from 2.0.0.Alpha1; fixed in 2.0.2.FInal

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-12196/ (Markdown: https://insights.sbomify.com/CVE-2017-12196/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-12196
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-12196
- OSV: https://osv.dev/vulnerability/CVE-2017-12196

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-12196/
Summaries are generated and may contain mistakes; the official description above is the record.
