{"answers":{"affected":"2 open source packages ship an affected version, including org.kohsuke:libpam4j. It affects 3 products.","exploited":"There is no known exploitation of CVE-2017-12197 in the wild and no public exploit code.","fix":"Upgrade org.kohsuke:libpam4j to 1.10 or later.","what":"CVE-2017-12197 is a medium-severity authentication bypass vulnerability in Debian Debian Linux, published on 18 Jan 2018. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2017-12197 and fix it if it is affected.\n\nWhat it is: CVE-2017-12197 is a medium-severity authentication bypass vulnerability in Debian Debian Linux, published on 18 Jan 2018. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2017-12197 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.kohsuke:libpam4j (Maven): affected all versions; fixed in 1.10\n- org.kohsuke:libpam4j (Maven): affected all versions; fixed in 1.10\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2017-12197/ (Markdown: https://insights.sbomify.com/CVE-2017-12197/index.md)","id":"CVE-2017-12197","markdown":"https://insights.sbomify.com/CVE-2017-12197/index.md","name":"CVE-2017-12197","record":{"aliases":["DLA-1165-1","DSA-4025-1","GHSA-x9rg-q5fx-fx66","MGASA-2018-0234","UBUNTU-CVE-2017-12197"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["security_bypass","data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Java PAM library","requires_auth":"low_privilege","summary":"Attackers with valid passwords for disabled accounts can bypass authentication restrictions and access sensitive information via libpam4j.","user_interaction":"not_required","vuln_class":"auth_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"debian_linux","vendor":"debian"},{"product":"libpam4j","vendor":"libpam4j_project"},{"product":"enterprise_linux","vendor":"redhat"}],"cvss":{"score":6.5,"severity":"medium","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N","version":"3.0"},"cwes":[{"id":"CWE-20","name":"Improper Input Validation"},{"id":"CWE-863","name":"Incorrect Authorization"}],"description":"It was found that libpam4j up to and including 1.8 did not properly validate user accounts when authenticating. A user with a valid password for a disabled account would be able to bypass security restrictions and possibly access sensitive information.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Improper Input Validation in libpam4j","id":"CVE-2017-12197","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":"debian:debian_linux","products":["debian:debian_linux","redhat:enterprise_linux"],"type":"auth_bypass","year":"2017"},"n_packages":2,"n_references":6,"next":{"headline":"SQL injection in n/a","id":"CVE-2017-12199"},"packages":[{"ecosystem":"Maven","fixed":["1.10"],"introduced":["0"],"last_affected":[],"package":"org.kohsuke:libpam4j","purl":null,"source":"GHSA-x9rg-q5fx-fx66"},{"ecosystem":"Maven","fixed":["1.10"],"introduced":["0"],"last_affected":[],"package":"org.kohsuke:libpam4j","purl":"pkg:maven/org.kohsuke/libpam4j","source":"GHSA-x9rg-q5fx-fx66"}],"prev":{"headline":"Incorrect Authorization in Undertow","id":"CVE-2017-12196"},"products":["libpam4j"],"published":"2018-01-18","related":[{"cvss_score":10,"headline":"ProFTPD Improper Access Control","id":"CVE-2015-3306","kev_date_added":"2026-10-08","published":"2015-05-18"},{"cvss_score":9.9,"headline":"RoundCube Webmail Deserialization of Untrusted Data","id":"CVE-2025-49113","kev_date_added":"2026-02-20","published":"2025-06-02"},{"cvss_score":9.8,"headline":"GNU InetUtils Argument Injection","id":"CVE-2026-24061","kev_date_added":"2026-01-26","published":"2026-01-21"},{"cvss_score":9.8,"headline":"Linux Kernel Improper Check for Unusual or Exceptional Conditions","id":"CVE-2025-39682","kev_date_added":"2026-09-18","published":"2025-09-05"},{"cvss_score":9.8,"headline":"Mozilla Firefox Use-After-Free","id":"CVE-2024-9680","kev_date_added":"2024-10-15","published":"2024-10-09"},{"cvss_score":9.8,"headline":"RARLAB UnRAR Directory Traversal","id":"CVE-2022-30333","kev_date_added":"2022-08-09","published":"2022-05-09"},{"cvss_score":9.8,"headline":"Roundcube Webmail SQL Injection","id":"CVE-2021-44026","kev_date_added":"2023-06-22","published":"2021-11-19"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["Red Hat, Inc."]},"summary":"Attackers with valid passwords for disabled accounts can bypass authentication restrictions and access sensitive information via libpam4j.","url":"https://insights.sbomify.com/CVE-2017-12197/"}