# CVE-2017-12197: Improper Input Validation in libpam4j

> Attackers with valid passwords for disabled accounts can bypass authentication restrictions and access sensitive information via libpam4j.

- **Severity:** Medium 6.5 (`CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 18 Jan 2018
- **Updated:** 5 Aug 2024
- **Also known as:** DLA-1165-1, DSA-4025-1, GHSA-x9rg-q5fx-fx66, MGASA-2018-0234, UBUNTU-CVE-2017-12197

## What is CVE-2017-12197?

CVE-2017-12197 is a medium-severity authentication bypass vulnerability in Debian Debian Linux, published on 18 Jan 2018. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

It was found that libpam4j up to and including 1.8 did not properly validate user accounts when authenticating. A user with a valid password for a disabled account would be able to bypass security restrictions and possibly access sensitive information.

Weakness: CWE-20 (Improper Input Validation), CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2017-12197?

2 open source packages ship an affected version, including org.kohsuke:libpam4j. It affects 3 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.kohsuke:libpam4j` | Maven | All versions | 1.10 |
| `org.kohsuke:libpam4j` | Maven | All versions | 1.10 |

Products: Debian Debian Linux, Libpam4j Project Libpam4j, Redhat Enterprise Linux.

## How do I fix CVE-2017-12197?

Upgrade org.kohsuke:libpam4j to 1.10 or later.

## Is CVE-2017-12197 being exploited?

There is no known exploitation of CVE-2017-12197 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-12197 and fix it if it is affected.

What it is: CVE-2017-12197 is a medium-severity authentication bypass vulnerability in Debian Debian Linux, published on 18 Jan 2018. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2017-12197 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.kohsuke:libpam4j (Maven): affected all versions; fixed in 1.10
- org.kohsuke:libpam4j (Maven): affected all versions; fixed in 1.10

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-12197/ (Markdown: https://insights.sbomify.com/CVE-2017-12197/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-12197
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-12197
- OSV: https://osv.dev/vulnerability/CVE-2017-12197

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-12197/
Summaries are generated and may contain mistakes; the official description above is the record.
