# CVE-2017-12440: Openstack Aodh can be used to launder Keystone trusts

> Authenticated users can bypass authorization checks to obtain Keystone tokens and perform actions using arbitrary trust IDs in OpenStack Aodh.

- **Severity:** High 7.5 (`CVSS:3.0/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 18 Aug 2017
- **Updated:** 5 Aug 2024
- **Also known as:** DEBIAN-CVE-2017-12440, DSA-3953-1, GHSA-86cv-9gpx-6hwj, PYSEC-2026-619, RHSA-2017:3227, RHSA-2018:0315, SUSE-SU-2017:2627-1, UBUNTU-CVE-2017-12440

## What is CVE-2017-12440?

CVE-2017-12440 is a high-severity missing authorization vulnerability in n/a, published on 18 Aug 2017. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Aodh as packaged in Openstack Ocata and Newton before change-ID I8fd11a7f9fe3c0ea5f9843a89686ac06713b7851 and before Pike-rc1 does not verify that trust IDs belong to the user when creating alarm action with the scheme trust+http, which allows remote authenticated users with knowledge of trust IDs where Aodh is the trustee to obtain a Keystone token and perform unspecified authenticated actions by adding an alarm action with the scheme trust+http, and providing a trust id where Aodh is the trustee.

Weakness: CWE-306 (Missing Authentication for Critical Functionality)

## Which versions are affected by CVE-2017-12440?

3 open source packages ship an affected version, including aodh. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `aodh` | PyPI | All versions | 6.0.1 |
| `aodh` | PyPI | All versions | 6.0.1 |
| `aodh` | PyPI | All versions | 6.0.1 |
| `openstack-aodh` | Red Hat:openstack:10::el7 | All versions | 0:3.0.4-1.el7ost |
| `openstack-aodh-api` | Red Hat:openstack:10::el7 | All versions | 0:3.0.4-1.el7ost |
| `openstack-aodh-common` | Red Hat:openstack:10::el7 | All versions | 0:3.0.4-1.el7ost |
| `openstack-aodh-compat` | Red Hat:openstack:10::el7 | All versions | 0:3.0.4-1.el7ost |
| `openstack-aodh-evaluator` | Red Hat:openstack:10::el7 | All versions | 0:3.0.4-1.el7ost |
| `openstack-aodh-expirer` | Red Hat:openstack:10::el7 | All versions | 0:3.0.4-1.el7ost |
| `openstack-aodh-listener` | Red Hat:openstack:10::el7 | All versions | 0:3.0.4-1.el7ost |
| `openstack-aodh-notifier` | Red Hat:openstack:10::el7 | All versions | 0:3.0.4-1.el7ost |
| `python-aodh` | Red Hat:openstack:10::el7 | All versions | 0:3.0.4-1.el7ost |
| `python-aodh-tests` | Red Hat:openstack:10::el7 | All versions | 0:3.0.4-1.el7ost |
| `openstack-aodh` | Red Hat:openstack:11::el7 | All versions | 0:4.0.2-3.el7ost |
| `openstack-aodh-api` | Red Hat:openstack:11::el7 | All versions | 0:4.0.2-3.el7ost |
| `openstack-aodh-common` | Red Hat:openstack:11::el7 | All versions | 0:4.0.2-3.el7ost |
| `openstack-aodh-compat` | Red Hat:openstack:11::el7 | All versions | 0:4.0.2-3.el7ost |
| `openstack-aodh-evaluator` | Red Hat:openstack:11::el7 | All versions | 0:4.0.2-3.el7ost |
| `openstack-aodh-expirer` | Red Hat:openstack:11::el7 | All versions | 0:4.0.2-3.el7ost |
| `openstack-aodh-listener` | Red Hat:openstack:11::el7 | All versions | 0:4.0.2-3.el7ost |
| `openstack-aodh-notifier` | Red Hat:openstack:11::el7 | All versions | 0:4.0.2-3.el7ost |
| `python-aodh` | Red Hat:openstack:11::el7 | All versions | 0:4.0.2-3.el7ost |
| `python-aodh-tests` | Red Hat:openstack:11::el7 | All versions | 0:4.0.2-3.el7ost |
| `openstack-aodh` | SUSE:OpenStack Cloud 7 | All versions | 3.0.4~a0~dev1-2.3.1 |
| `openstack-aodh-doc` | SUSE:OpenStack Cloud 7 | All versions | 3.0.4~a0~dev1-2.3.1 |

Products: Openstack Openstack.

## How do I fix CVE-2017-12440?

Upgrade aodh to 6.0.1 or later.

## Is CVE-2017-12440 being exploited?

There is no known exploitation of CVE-2017-12440 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-12440 and fix it if it is affected.

What it is: CVE-2017-12440 is a high-severity missing authorization vulnerability in n/a, published on 18 Aug 2017. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2017-12440 in the wild and no public exploit code.

Affected packages and fixed versions:
- aodh (PyPI): affected all versions; fixed in 6.0.1
- aodh (PyPI): affected all versions; fixed in 6.0.1
- aodh (PyPI): affected all versions; fixed in 6.0.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-12440/ (Markdown: https://insights.sbomify.com/CVE-2017-12440/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-12440
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-12440
- OSV: https://osv.dev/vulnerability/CVE-2017-12440

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-12440/
Summaries are generated and may contain mistakes; the official description above is the record.
