# CVE-2017-12581: Electron vulnerable to remote command execution

> Remote attackers can execute arbitrary OS commands on user hosts by bypassing Same Origin Policy and exploiting privileged Electron URLs.

- **Severity:** High 8.1 (`CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Aug 2017
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-7fv9-m79r-j9x8

## What is CVE-2017-12581?

CVE-2017-12581 is a high-severity command injection vulnerability in n/a, published on 6 Aug 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

GitHub Electron before 1.6.8 allows remote command execution because of a nodeIntegration bypass vulnerability. This also affects all applications that bundle Electron code equivalent to 1.6.8 or earlier. Bypassing the Same Origin Policy (SOP) is a precondition; however, recent Electron versions do not have strict SOP enforcement. Combining an SOP bypass with a privileged URL internally used by Electron, it was possible to execute native Node.js primitives in order to run OS commands on the user's host. Specifically, a chrome-devtools://devtools/bundled/inspector.html window could be used to eval a Node.js child_process.execFile API call.

Weakness: CWE-78 (Improper Neutralization of Special Elements used in an OS Command)

## Which versions are affected by CVE-2017-12581?

2 open source packages ship an affected version, including electron. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `electron` | npm | All versions | 1.6.8 |
| `electron` | npm | All versions | 1.6.8 |

Products: Electron Electron.

## How do I fix CVE-2017-12581?

Upgrade electron to 1.6.8 or later.

## Is CVE-2017-12581 being exploited?

There is no known exploitation of CVE-2017-12581 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-12581 and fix it if it is affected.

What it is: CVE-2017-12581 is a high-severity command injection vulnerability in n/a, published on 6 Aug 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2017-12581 in the wild and no public exploit code.

Affected packages and fixed versions:
- electron (npm): affected all versions; fixed in 1.6.8
- electron (npm): affected all versions; fixed in 1.6.8

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-12581/ (Markdown: https://insights.sbomify.com/CVE-2017-12581/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-12581
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-12581
- OSV: https://osv.dev/vulnerability/CVE-2017-12581

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-12581/
Summaries are generated and may contain mistakes; the official description above is the record.
