CVE-2017-12611 Apache Struts 2.0.1 uses an unintentional expression in a Freemarker tag instead of string literal
Attackers can execute arbitrary code by exploiting improper input handling in Freemarker tags within Apache Struts applications.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2017-12611?
CVE-2017-12611 is a critical code injection vulnerability in Apache Struts, published on 20 Sep 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
In Apache Struts 2.0.0 through 2.3.33 and 2.5 through 2.5.10.1, using an unintentional expression in a Freemarker tag instead of string literals can lead to a RCE attack.
Weakness: CWE-20
Which versions are affected by CVE-2017-12611?
4 open source packages ship an affected version, including org.apache.struts:struts2-core. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
org.apache.struts:struts2-core Maven | From 2.0.1 | 2.3.34 |
org.apache.struts:struts2-core Maven | From 2.0.1 | 2.3.34 |
org.apache.struts:struts2-core Maven | From 2.5.0 | 2.5.11 |
org.apache.struts:struts2-core Maven | From 2.5.0 | 2.5.11 |
Products include Apache Struts.
How do I fix CVE-2017-12611?
Upgrade org.apache.struts:struts2-core to a fixed version for your release line: 2.3.34 or 2.5.11.
Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.
Is CVE-2017-12611 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2017-12611 exists.
Public exploit code: 1 Exploit-DB entry, 1 Nuclei template and 3 proofs of concept on GitHub.
Other vulnerabilities in Apache Struts
Sources
Also known as GHSA-8fx9-5hx8-crhm.