# CVE-2017-12611: Apache Struts 2.0.1 uses an unintentional expression in a Freemarker tag instead of string literal

> Attackers can execute arbitrary code by exploiting improper input handling in Freemarker tags within Apache Struts applications.

- **Severity:** Critical 9.8 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 20 Sep 2017
- **Updated:** 17 Sep 2024
- **Also known as:** GHSA-8fx9-5hx8-crhm

## What is CVE-2017-12611?

CVE-2017-12611 is a critical code injection vulnerability in Apache Struts, published on 20 Sep 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

In Apache Struts 2.0.0 through 2.3.33 and 2.5 through 2.5.10.1, using an unintentional expression in a Freemarker tag instead of string literals can lead to a RCE attack.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2017-12611?

4 open source packages ship an affected version, including org.apache.struts:struts2-core. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.struts:struts2-core` | Maven | From 2.0.1 | 2.3.34 |
| `org.apache.struts:struts2-core` | Maven | From 2.0.1 | 2.3.34 |
| `org.apache.struts:struts2-core` | Maven | From 2.5.0 | 2.5.11 |
| `org.apache.struts:struts2-core` | Maven | From 2.5.0 | 2.5.11 |

Products: Apache Struts.

## How do I fix CVE-2017-12611?

Upgrade org.apache.struts:struts2-core to a fixed version for your release line: 2.3.34 or 2.5.11.

## Is CVE-2017-12611 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2017-12611 exists.

Public exploit code:

- A simple script for exploit RCE for Struts 2 S2-053(CVE-2017-12611) (github_poc): https://github.com/brianwrf/S2-053-CVE-2017-12611
- Apache Struts 2.0.1 < 2.3.33 / 2.5 < 2.5.10 - Arbitrary Code Execution (exploitdb)
- https://github.com/tcetin704/CVE-2017-12611 (github_poc): https://github.com/tcetin704/CVE-2017-12611
- RCE project (github_poc): https://github.com/zeynepsilao/CVE-2017-12611_Exploit
- Apache Struts2 S2-053 - Remote Code Execution (nuclei): http/cves/2017/CVE-2017-12611.yaml

## Other vulnerabilities in Apache Struts

- [CVE-2020-17530](https://insights.sbomify.com/CVE-2020-17530/): Apache Struts Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2017-9791](https://insights.sbomify.com/CVE-2017-9791/): Apache Struts 1 Improper Input Validation (critical 9.8, exploited in the wild)
- [CVE-2017-5638](https://insights.sbomify.com/CVE-2017-5638/): Apache Struts Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2012-0391](https://insights.sbomify.com/CVE-2012-0391/): Apache Struts 2 Improper Input Validation (critical 9.8, exploited in the wild)
- [CVE-2018-11776](https://insights.sbomify.com/CVE-2018-11776/): Apache Struts Remote Code Execution (high 8.1, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-12611 and fix it if it is affected.

What it is: CVE-2017-12611 is a critical code injection vulnerability in Apache Struts, published on 20 Sep 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2017-12611 exists.

Affected packages and fixed versions:
- org.apache.struts:struts2-core (Maven): affected from 2.0.1; fixed in 2.3.34
- org.apache.struts:struts2-core (Maven): affected from 2.0.1; fixed in 2.3.34
- org.apache.struts:struts2-core (Maven): affected from 2.5.0; fixed in 2.5.11
- org.apache.struts:struts2-core (Maven): affected from 2.5.0; fixed in 2.5.11

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-12611/ (Markdown: https://insights.sbomify.com/CVE-2017-12611/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-12611
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-12611
- OSV: https://osv.dev/vulnerability/CVE-2017-12611

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-12611/
Summaries are generated and may contain mistakes; the official description above is the record.
