{"answers":{"affected":"7 open source packages ship an affected version, including pyspark, org.apache.spark:spark-core_2.10 and org.apache.spark:spark-core_2.11. It affects 1 product.","exploited":"There is no known exploitation of CVE-2017-12612 in the wild and no public exploit code.","fix":"Upgrade pyspark to 2.1.2 or later.","what":"CVE-2017-12612 is a high-severity unsafe deserialization vulnerability in n/a, published on 13 Sep 2017. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2017-12612 and fix it if it is affected.\n\nWhat it is: CVE-2017-12612 is a high-severity unsafe deserialization vulnerability in n/a, published on 13 Sep 2017. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2017-12612 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- pyspark (PyPI): affected all versions; fixed in 2.1.2\n- pyspark (PyPI): affected all versions; fixed in 2.1.2\n- pyspark (PyPI): affected all versions; fixed in 2.1.2\n- org.apache.spark:spark-core_2.10 (Maven): affected all versions; fixed in 2.1.2\n- org.apache.spark:spark-core_2.10 (Maven): affected all versions; fixed in 2.1.2\n- org.apache.spark:spark-core_2.11 (Maven): affected all versions; fixed in 2.1.2\n- org.apache.spark:spark-core_2.11 (Maven): affected all versions; fixed in 2.1.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2017-12612/ (Markdown: https://insights.sbomify.com/CVE-2017-12612/index.md)","id":"CVE-2017-12612","markdown":"https://insights.sbomify.com/CVE-2017-12612/index.md","name":"CVE-2017-12612","record":{"aliases":["GHSA-8rhc-48pp-52gr","PYSEC-2017-147"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"Apache Spark launcher","requires_auth":"low_privilege","summary":"An attacker with local access can execute arbitrary code via unsafe deserialization in the Apache Spark launcher API socket.","user_interaction":"not_required","vuln_class":"deserialization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"apache","cpe":[{"product":"spark","vendor":"apache"}],"cvss":{"score":7.8,"severity":"high","source":"nvd","vector":"CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H","version":"3.0"},"cwes":[{"id":"CWE-502","name":"Deserialization of Untrusted Data"}],"description":"In Apache Spark 1.6.0 until 2.1.1, the launcher API performs unsafe deserialization of data received by its socket. This makes applications launched programmatically using the launcher API potentially vulnerable to arbitrary code execution by an attacker with access to any user account on the local machine. It does not affect apps run by spark-submit or spark-shell. The attacker would be able to execute code as the user that ran the Spark application. Users are encouraged to update to version 2.2.0 or later.","ecosystems":["Maven","PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Apache Spark Deserialization of Untrusted Data vulnerability","id":"CVE-2017-12612","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"deserialization","year":"2017"},"n_packages":7,"n_references":2,"next":{"headline":"Information disclosure in Apache Portable Runtime","id":"CVE-2017-12613"},"packages":[{"ecosystem":"Maven","fixed":["2.1.2"],"introduced":["0"],"last_affected":[],"package":"org.apache.spark:spark-core_2.10","purl":null,"source":"GHSA-8rhc-48pp-52gr"},{"ecosystem":"Maven","fixed":["2.1.2"],"introduced":["0"],"last_affected":[],"package":"org.apache.spark:spark-core_2.10","purl":"pkg:maven/org.apache.spark/spark-core_2.10","source":"GHSA-8rhc-48pp-52gr"},{"ecosystem":"Maven","fixed":["2.1.2"],"introduced":["0"],"last_affected":[],"package":"org.apache.spark:spark-core_2.11","purl":null,"source":"GHSA-8rhc-48pp-52gr"},{"ecosystem":"Maven","fixed":["2.1.2"],"introduced":["0"],"last_affected":[],"package":"org.apache.spark:spark-core_2.11","purl":"pkg:maven/org.apache.spark/spark-core_2.11","source":"GHSA-8rhc-48pp-52gr"},{"ecosystem":"PyPI","fixed":["2.1.2"],"introduced":["0"],"last_affected":[],"package":"pyspark","purl":null,"source":"GHSA-8rhc-48pp-52gr"},{"ecosystem":"PyPI","fixed":["2.1.2"],"introduced":["0"],"last_affected":[],"package":"pyspark","purl":"pkg:pypi/pyspark","source":"GHSA-8rhc-48pp-52gr"},{"ecosystem":"PyPI","fixed":["2.1.2"],"introduced":["0"],"last_affected":[],"package":"pyspark","purl":"pkg:pypi/pyspark","source":"PYSEC-2017-147"}],"prev":{"headline":"Apache Struts 2.0.1 uses an unintentional expression in a Freemarker tag instead of string literal","id":"CVE-2017-12611"},"products":["n/a"],"published":"2017-09-13","related":[{"cvss_score":8.8,"headline":"Apache Spark Command Injection","id":"CVE-2022-33891","kev_date_added":"2023-03-07","published":"2022-07-18"},{"cvss_score":9.8,"headline":"Improper Authentication in Apache Spark","id":"CVE-2020-9480","kev_date_added":null,"published":"2020-06-23"},{"cvss_score":9.8,"headline":"Remote Code Execution in spark-core","id":"CVE-2018-17190","kev_date_added":null,"published":"2018-11-19"},{"cvss_score":9.1,"headline":"HTTP Request Smuggling in Netty","id":"CVE-2019-20445","kev_date_added":null,"published":"2020-01-29"},{"cvss_score":8.8,"headline":"Apache Spark: Spark History Server Code Execution Vulnerability","id":"CVE-2025-54920","kev_date_added":null,"published":"2026-03-14"},{"cvss_score":8.8,"headline":"Apache Spark: Shell command injection via Spark UI","id":"CVE-2023-32007","kev_date_added":null,"published":"2023-05-02"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"An attacker with local access can execute arbitrary code via unsafe deserialization in the Apache Spark launcher API socket.","url":"https://insights.sbomify.com/CVE-2017-12612/"}