# CVE-2017-12612: Apache Spark Deserialization of Untrusted Data vulnerability

> An attacker with local access can execute arbitrary code via unsafe deserialization in the Apache Spark launcher API socket.

- **Severity:** High 7.8 (`CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 13 Sep 2017
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-8rhc-48pp-52gr, PYSEC-2017-147

## What is CVE-2017-12612?

CVE-2017-12612 is a high-severity unsafe deserialization vulnerability in n/a, published on 13 Sep 2017. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

In Apache Spark 1.6.0 until 2.1.1, the launcher API performs unsafe deserialization of data received by its socket. This makes applications launched programmatically using the launcher API potentially vulnerable to arbitrary code execution by an attacker with access to any user account on the local machine. It does not affect apps run by spark-submit or spark-shell. The attacker would be able to execute code as the user that ran the Spark application. Users are encouraged to update to version 2.2.0 or later.

Weakness: CWE-502 (Deserialization of Untrusted Data)

## Which versions are affected by CVE-2017-12612?

7 open source packages ship an affected version, including pyspark, org.apache.spark:spark-core_2.10 and org.apache.spark:spark-core_2.11. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pyspark` | PyPI | All versions | 2.1.2 |
| `pyspark` | PyPI | All versions | 2.1.2 |
| `pyspark` | PyPI | All versions | 2.1.2 |
| `org.apache.spark:spark-core_2.10` | Maven | All versions | 2.1.2 |
| `org.apache.spark:spark-core_2.10` | Maven | All versions | 2.1.2 |
| `org.apache.spark:spark-core_2.11` | Maven | All versions | 2.1.2 |
| `org.apache.spark:spark-core_2.11` | Maven | All versions | 2.1.2 |

Products: Apache Spark.

## How do I fix CVE-2017-12612?

Upgrade pyspark to 2.1.2 or later.

## Is CVE-2017-12612 being exploited?

There is no known exploitation of CVE-2017-12612 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2022-33891](https://insights.sbomify.com/CVE-2022-33891/): Apache Spark Command Injection (high 8.8, exploited in the wild)
- [CVE-2020-9480](https://insights.sbomify.com/CVE-2020-9480/): Improper Authentication in Apache Spark (critical 9.8)
- [CVE-2018-17190](https://insights.sbomify.com/CVE-2018-17190/): Remote Code Execution in spark-core (critical 9.8)
- [CVE-2019-20445](https://insights.sbomify.com/CVE-2019-20445/): HTTP Request Smuggling in Netty (critical 9.1)
- [CVE-2025-54920](https://insights.sbomify.com/CVE-2025-54920/): Apache Spark: Spark History Server Code Execution Vulnerability (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-12612 and fix it if it is affected.

What it is: CVE-2017-12612 is a high-severity unsafe deserialization vulnerability in n/a, published on 13 Sep 2017. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2017-12612 in the wild and no public exploit code.

Affected packages and fixed versions:
- pyspark (PyPI): affected all versions; fixed in 2.1.2
- pyspark (PyPI): affected all versions; fixed in 2.1.2
- pyspark (PyPI): affected all versions; fixed in 2.1.2
- org.apache.spark:spark-core_2.10 (Maven): affected all versions; fixed in 2.1.2
- org.apache.spark:spark-core_2.10 (Maven): affected all versions; fixed in 2.1.2
- org.apache.spark:spark-core_2.11 (Maven): affected all versions; fixed in 2.1.2
- org.apache.spark:spark-core_2.11 (Maven): affected all versions; fixed in 2.1.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-12612/ (Markdown: https://insights.sbomify.com/CVE-2017-12612/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-12612
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-12612
- OSV: https://osv.dev/vulnerability/CVE-2017-12612

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-12612/
Summaries are generated and may contain mistakes; the official description above is the record.
