{"answers":{"affected":"3 open source packages ship an affected version, including apache-airflow. It affects 1 product.","exploited":"There is no known exploitation of CVE-2017-12614 in the wild and no public exploit code.","fix":"Upgrade apache-airflow to 1.9.0 or later.","what":"CVE-2017-12614 is a medium-severity cross-site scripting vulnerability in Apache Airflow, published on 6 Aug 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2017-12614 and fix it if it is affected.\n\nWhat it is: CVE-2017-12614 is a medium-severity cross-site scripting vulnerability in Apache Airflow, published on 6 Aug 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2017-12614 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- apache-airflow (PyPI): affected all versions; fixed in 1.9.0\n- apache-airflow (PyPI): affected all versions; fixed in 1.9.0\n- apache-airflow (PyPI): affected all versions; fixed in 1.9.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2017-12614/ (Markdown: https://insights.sbomify.com/CVE-2017-12614/index.md)","id":"CVE-2017-12614","markdown":"https://insights.sbomify.com/CVE-2017-12614/index.md","name":"CVE-2017-12614","record":{"aliases":["GHSA-rv25-9wgj-xg75","PYSEC-2018-45"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Apache Airflow","requires_auth":"none","summary":"An attacker can execute arbitrary scripts in victim browsers via reflected XSS in Apache Airflow 404 error pages.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"apache","cpe":[{"product":"airflow","vendor":"apache"}],"cvss":{"score":6.1,"severity":"medium","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","version":"3.0"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"It was noticed an XSS in certain 404 pages that could be exploited to perform an XSS attack. Chrome will detect this as a reflected XSS attempt and prevent the page from loading. Firefox and other browsers don't, and are vulnerable to this attack. Mitigation: The fix for this is to upgrade to Apache Airflow 1.9.0 or above.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Apache Airflow Reflected Cross-site Scripting vulnerability in 404 Endpoint","id":"CVE-2017-12614","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":"apache:airflow","products":["apache:airflow"],"type":"xss","year":"2017"},"n_packages":3,"n_references":1,"next":{"headline":"Apache Tomcat on Windows Remote Code Execution","id":"CVE-2017-12615"},"packages":[{"ecosystem":"PyPI","fixed":["1.9.0"],"introduced":["0"],"last_affected":[],"package":"apache-airflow","purl":null,"source":"GHSA-rv25-9wgj-xg75"},{"ecosystem":"PyPI","fixed":["1.9.0"],"introduced":["0"],"last_affected":[],"package":"apache-airflow","purl":"pkg:pypi/apache-airflow","source":"GHSA-rv25-9wgj-xg75"},{"ecosystem":"PyPI","fixed":["1.9.0"],"introduced":["0"],"last_affected":[],"package":"apache-airflow","purl":"pkg:pypi/apache-airflow","source":"PYSEC-2018-45"}],"prev":{"headline":"Information disclosure in Apache Portable Runtime","id":"CVE-2017-12613"},"products":["Apache Airflow"],"published":"2018-08-06","related":[{"cvss_score":9.8,"headline":"Apache Airflow's Experimental API Authentication Bypass","id":"CVE-2020-13927","kev_date_added":"2022-01-18","published":"2020-11-10"},{"cvss_score":8.8,"headline":"Apache Airflow Command Injection","id":"CVE-2020-11978","kev_date_added":"2022-01-18","published":"2020-07-16"},{"cvss_score":9.8,"headline":"Apache Airflow: DAG author RCE on webserver via unrestricted import_string() in BaseSerialization.deserialize()","id":"CVE-2026-33264","kev_date_added":null,"published":"2026-07-07"},{"cvss_score":9.8,"headline":"Apache Airflow: Privilege escalation using airflow logs","id":"CVE-2023-25754","kev_date_added":null,"published":"2023-05-08"},{"cvss_score":9.8,"headline":"Apache Airflow, Apache Airflow MySQL Provider: Arbitrary file read via MySQL provider in Apache Airflow","id":"CVE-2023-22884","kev_date_added":null,"published":"2023-01-21"},{"cvss_score":9.8,"headline":"Apache Airflow Pinot provider allowed Command Injection","id":"CVE-2022-38649","kev_date_added":null,"published":"2022-11-22"},{"cvss_score":9.8,"headline":"Apache Airlfow Pig Provider RCE","id":"CVE-2022-40189","kev_date_added":null,"published":"2022-11-22"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-16","vendors":["Apache Software Foundation"]},"summary":"An attacker can execute arbitrary scripts in victim browsers via reflected XSS in Apache Airflow 404 error pages.","url":"https://insights.sbomify.com/CVE-2017-12614/"}