# CVE-2017-12614: Apache Airflow Reflected Cross-site Scripting vulnerability in 404 Endpoint

> An attacker can execute arbitrary scripts in victim browsers via reflected XSS in Apache Airflow 404 error pages.

- **Severity:** Medium 6.1 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 6 Aug 2018
- **Updated:** 16 Sep 2024
- **Also known as:** GHSA-rv25-9wgj-xg75, PYSEC-2018-45

## What is CVE-2017-12614?

CVE-2017-12614 is a medium-severity cross-site scripting vulnerability in Apache Airflow, published on 6 Aug 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

It was noticed an XSS in certain 404 pages that could be exploited to perform an XSS attack. Chrome will detect this as a reflected XSS attempt and prevent the page from loading. Firefox and other browsers don't, and are vulnerable to this attack. Mitigation: The fix for this is to upgrade to Apache Airflow 1.9.0 or above.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2017-12614?

3 open source packages ship an affected version, including apache-airflow. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `apache-airflow` | PyPI | All versions | 1.9.0 |
| `apache-airflow` | PyPI | All versions | 1.9.0 |
| `apache-airflow` | PyPI | All versions | 1.9.0 |

Products: Apache Airflow.

## How do I fix CVE-2017-12614?

Upgrade apache-airflow to 1.9.0 or later.

## Is CVE-2017-12614 being exploited?

There is no known exploitation of CVE-2017-12614 in the wild and no public exploit code.

## Other vulnerabilities in Apache Airflow

- [CVE-2020-13927](https://insights.sbomify.com/CVE-2020-13927/): Apache Airflow's Experimental API Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2020-11978](https://insights.sbomify.com/CVE-2020-11978/): Apache Airflow Command Injection (high 8.8, exploited in the wild)
- [CVE-2026-33264](https://insights.sbomify.com/CVE-2026-33264/): Apache Airflow: DAG author RCE on webserver via unrestricted import_string() in BaseSerialization.deserialize() (critical 9.8)
- [CVE-2023-25754](https://insights.sbomify.com/CVE-2023-25754/): Apache Airflow: Privilege escalation using airflow logs (critical 9.8)
- [CVE-2023-22884](https://insights.sbomify.com/CVE-2023-22884/): Apache Airflow, Apache Airflow MySQL Provider: Arbitrary file read via MySQL provider in Apache Airflow (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-12614 and fix it if it is affected.

What it is: CVE-2017-12614 is a medium-severity cross-site scripting vulnerability in Apache Airflow, published on 6 Aug 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2017-12614 in the wild and no public exploit code.

Affected packages and fixed versions:
- apache-airflow (PyPI): affected all versions; fixed in 1.9.0
- apache-airflow (PyPI): affected all versions; fixed in 1.9.0
- apache-airflow (PyPI): affected all versions; fixed in 1.9.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-12614/ (Markdown: https://insights.sbomify.com/CVE-2017-12614/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-12614
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-12614
- OSV: https://osv.dev/vulnerability/CVE-2017-12614

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-12614/
Summaries are generated and may contain mistakes; the official description above is the record.
