CVE-2017-12616 Exposure of Sensitive Information to an Unauthorized Actor in Apache Tomcat
Attackers can bypass security constraints and view JSP source code in Apache Tomcat when using VirtualDirContext.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2017-12616?
CVE-2017-12616 is a high-severity vulnerability in Apache Tomcat, published on 19 Sep 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
When using a VirtualDirContext with Apache Tomcat 7.0.0 to 7.0.80 it was possible to bypass security constraints and/or view the source code of JSPs for resources served by the VirtualDirContext using a specially crafted request.
Weakness: CWE-200
Which versions are affected by CVE-2017-12616?
2 open source packages ship an affected version, including org.apache.tomcat:tomcat-catalina. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
org.apache.tomcat:tomcat-catalina Maven | From 7.0.0 | 7.0.81 |
org.apache.tomcat:tomcat-catalina Maven | From 7.0.0 | 7.0.81 |
Products include Apache Tomcat.
How do I fix CVE-2017-12616?
Upgrade org.apache.tomcat:tomcat-catalina to 7.0.81 or later.
Is CVE-2017-12616 being exploited?
There is no known exploitation of CVE-2017-12616 in the wild and no public exploit code.
Other vulnerabilities in Apache Tomcat
Sources
Also known as DLA-1108-1, GHSA-8qq4-8jvq-mfw4, UBUNTU-CVE-2017-12616.