CVE-2017-12620 Improper Restriction of XML External Entity Reference in Apache OpenNLP

Critical 9.8 Published Updated

Attackers can perform XML External Entity attacks by loading malicious models or dictionaries, potentially reading sensitive data or causing denial of service.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2017-12620?

CVE-2017-12620 is a critical vulnerability in Apache OpenNLP, published on 2 Oct 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

When loading models or dictionaries that contain XML it is possible to perform an XXE attack, since Apache OpenNLP is a library, this only affects applications that load models or dictionaries from untrusted sources. The versions 1.5.0 to 1.5.3, 1.6.0, 1.7.0 to 1.7.2, 1.8.0 to 1.8.1 of Apache OpenNLP are affected.

Weakness: CWE-611

Which versions are affected by CVE-2017-12620?

2 open source packages ship an affected version, including org.apache.opennlp:opennlp-tools. It affects 1 product.

PackageAffectedFixed in
org.apache.opennlp:opennlp-tools MavenFrom 1.5.01.8.2
org.apache.opennlp:opennlp-tools MavenFrom 1.5.01.8.2

Products include Apache Opennlp.

How do I fix CVE-2017-12620?

Upgrade org.apache.opennlp:opennlp-tools to 1.8.2 or later.

Is CVE-2017-12620 being exploited?

There is no known exploitation of CVE-2017-12620 in the wild and no public exploit code.

Sources

Also known as GHSA-h22x-hm8g-rxpg.

Is CVE-2017-12620 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free