{"answers":{"affected":"2 open source packages ship an affected version, including org.apache.opennlp:opennlp-tools. It affects 1 product.","exploited":"There is no known exploitation of CVE-2017-12620 in the wild and no public exploit code.","fix":"Upgrade org.apache.opennlp:opennlp-tools to 1.8.2 or later.","what":"CVE-2017-12620 is a critical vulnerability in Apache OpenNLP, published on 2 Oct 2017. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2017-12620 and fix it if it is affected.\n\nWhat it is: CVE-2017-12620 is a critical vulnerability in Apache OpenNLP, published on 2 Oct 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2017-12620 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.apache.opennlp:opennlp-tools (Maven): affected from 1.5.0; fixed in 1.8.2\n- org.apache.opennlp:opennlp-tools (Maven): affected from 1.5.0; fixed in 1.8.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2017-12620/ (Markdown: https://insights.sbomify.com/CVE-2017-12620/index.md)","id":"CVE-2017-12620","markdown":"https://insights.sbomify.com/CVE-2017-12620/index.md","name":"CVE-2017-12620","record":{"aliases":["GHSA-h22x-hm8g-rxpg"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read","denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Apache OpenNLP library","requires_auth":"none","summary":"Attackers can perform XML External Entity attacks by loading malicious models or dictionaries, potentially reading sensitive data or causing denial of service.","user_interaction":"not_required","vuln_class":"xxe"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"apache","cpe":[{"product":"opennlp","vendor":"apache"}],"cvss":{"score":9.8,"severity":"critical","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.0"},"cwes":[{"id":"CWE-611","name":"Improper Restriction of XML External Entity Reference"}],"description":"When loading models or dictionaries that contain XML it is possible to perform an XXE attack, since Apache OpenNLP is a library, this only affects applications that load models or dictionaries from untrusted sources. The versions 1.5.0 to 1.5.3, 1.6.0, 1.7.0 to 1.7.2, 1.8.0 to 1.8.1 of Apache OpenNLP are affected.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Improper Restriction of XML External Entity Reference in Apache OpenNLP","id":"CVE-2017-12620","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"xxe","year":"2017"},"n_packages":2,"n_references":1,"next":{"headline":"Improper Restriction of XML External Entity Reference in Jelly","id":"CVE-2017-12621"},"packages":[{"ecosystem":"Maven","fixed":["1.8.2"],"introduced":["1.5.0"],"last_affected":[],"package":"org.apache.opennlp:opennlp-tools","purl":null,"source":"GHSA-h22x-hm8g-rxpg"},{"ecosystem":"Maven","fixed":["1.8.2"],"introduced":["1.5.0"],"last_affected":[],"package":"org.apache.opennlp:opennlp-tools","purl":"pkg:maven/org.apache.opennlp/opennlp-tools","source":"GHSA-h22x-hm8g-rxpg"}],"prev":{"headline":"Session Fixation in Apache Zeppelin","id":"CVE-2017-12619"},"products":["Apache OpenNLP"],"published":"2017-10-02","related":[{"cvss_score":10,"headline":"Apache OpenNLP, Apache OpenNLP: ReDoS / stack exhaustion in RegexNameFinderFactory built-in EMAIL and URL patterns","id":"CVE-2026-82617","kev_date_added":null,"published":"2026-09-11"},{"cvss_score":9.8,"headline":"Apache OpenNLP: Arbitrary Class Instantiation via Model Manifest in ExtensionLoader","id":"CVE-2026-42027","kev_date_added":null,"published":"2026-05-04"},{"cvss_score":9.1,"headline":"Apache OpenNLP: XXE via Dictionary Parsing in DictionaryEntryPersistor","id":"CVE-2026-40682","kev_date_added":null,"published":"2026-05-04"},{"cvss_score":7.5,"headline":"Apache OpenNLP: OOM DoS via Unbounded Array Allocation in SymSpellModelSerializer","id":"CVE-2026-67211","kev_date_added":null,"published":"2026-09-11"},{"cvss_score":7.5,"headline":"Apache OpenNLP: OOM DoS via Unbounded Array Allocation in AbstractModelReader","id":"CVE-2026-42440","kev_date_added":null,"published":"2026-05-04"},{"cvss_score":7.3,"headline":"Apache OpenNLP :: Core :: ML :: LibSVM: Unsafe Java Deserialization in SvmDoccatModel","id":"CVE-2026-43825","kev_date_added":null,"published":"2026-07-06"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-16","vendors":["Apache Software Foundation"]},"summary":"Attackers can perform XML External Entity attacks by loading malicious models or dictionaries, potentially reading sensitive data or causing denial of service.","url":"https://insights.sbomify.com/CVE-2017-12620/"}