# CVE-2017-12621: Improper Restriction of XML External Entity Reference in Jelly

> An attacker can exploit XML External Entity vulnerabilities in Apache Commons Jelly to read sensitive data or cause denial of service.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 27 Sep 2017
- **Updated:** 16 Sep 2024
- **Also known as:** GHSA-6g33-82gc-3pw5, UBUNTU-CVE-2017-12621

## What is CVE-2017-12621?

CVE-2017-12621 is a critical vulnerability in Apache Commons Jelly, published on 27 Sep 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

During Jelly (xml) file parsing with Apache Xerces, if a custom doctype entity is declared with a "SYSTEM" entity with a URL and that entity is used in the body of the Jelly file, during parser instantiation the parser will attempt to connect to said URL. This could lead to XML External Entity (XXE) attacks in Apache Commons Jelly before 1.0.1.

Weakness: CWE-611 (Improper Restriction of XML External Entity Reference)

## Which versions are affected by CVE-2017-12621?

2 open source packages ship an affected version, including commons-jelly:commons-jelly. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `commons-jelly:commons-jelly` | Maven | All versions | 1.0.1 |
| `commons-jelly:commons-jelly` | Maven | All versions | 1.0.1 |

Products: Apache Commons Jelly.

## How do I fix CVE-2017-12621?

Upgrade commons-jelly:commons-jelly to 1.0.1 or later.

## Is CVE-2017-12621 being exploited?

There is no known exploitation of CVE-2017-12621 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-12621 and fix it if it is affected.

What it is: CVE-2017-12621 is a critical vulnerability in Apache Commons Jelly, published on 27 Sep 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2017-12621 in the wild and no public exploit code.

Affected packages and fixed versions:
- commons-jelly:commons-jelly (Maven): affected all versions; fixed in 1.0.1
- commons-jelly:commons-jelly (Maven): affected all versions; fixed in 1.0.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-12621/ (Markdown: https://insights.sbomify.com/CVE-2017-12621/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-12621
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-12621
- OSV: https://osv.dev/vulnerability/CVE-2017-12621

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-12621/
Summaries are generated and may contain mistakes; the official description above is the record.
