{"answers":{"affected":"2 open source packages ship an affected version, including org.apache.nifi:nifi. It affects 1 product.","exploited":"There is no known exploitation of CVE-2017-12623 in the wild and no public exploit code.","fix":"Upgrade org.apache.nifi:nifi to 1.4.0 or later.","what":"CVE-2017-12623 is a medium-severity vulnerability in Apache Nifi, published on 10 Oct 2017. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2017-12623 and fix it if it is affected.\n\nWhat it is: CVE-2017-12623 is a medium-severity vulnerability in Apache Nifi, published on 10 Oct 2017. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2017-12623 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.apache.nifi:nifi (Maven): affected from 1.0.0; fixed in 1.4.0\n- org.apache.nifi:nifi (Maven): affected from 1.0.0; fixed in 1.4.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2017-12623/ (Markdown: https://insights.sbomify.com/CVE-2017-12623/index.md)","id":"CVE-2017-12623","markdown":"https://insights.sbomify.com/CVE-2017-12623/index.md","name":"CVE-2017-12623","record":{"aliases":["GHSA-qj7f-j6h9-g5rq"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Apache NiFi","requires_auth":"low_privilege","summary":"An authorized user can exploit an XML External Entity vulnerability in Apache NiFi to access sensitive files via malicious templates.","user_interaction":"not_required","vuln_class":"xxe"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"apache","cpe":[{"product":"nifi","vendor":"apache"}],"cvss":{"score":6.5,"severity":"medium","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N","version":"3.0"},"cwes":[{"id":"CWE-611","name":"Improper Restriction of XML External Entity Reference"}],"description":"An authorized user could upload a template which contained malicious code and accessed sensitive files via an XML External Entity (XXE) attack. The fix to properly handle XML External Entities was applied on the Apache NiFi 1.4.0 release. Users running a prior 1.x release should upgrade to the appropriate release.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"XML External Entity Reference in Apache NiFi","id":"CVE-2017-12623","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":"apache:nifi","products":["apache:nifi"],"type":"xxe","year":"2017"},"n_packages":2,"n_references":1,"next":{"headline":"Improper Input Validation in Apache CXF","id":"CVE-2017-12624"},"packages":[{"ecosystem":"Maven","fixed":["1.4.0"],"introduced":["1.0.0"],"last_affected":[],"package":"org.apache.nifi:nifi","purl":null,"source":"GHSA-qj7f-j6h9-g5rq"},{"ecosystem":"Maven","fixed":["1.4.0"],"introduced":["1.0.0"],"last_affected":[],"package":"org.apache.nifi:nifi","purl":"pkg:maven/org.apache.nifi/nifi","source":"GHSA-qj7f-j6h9-g5rq"}],"prev":{"headline":"Apache Geode gfsh authorization vulnerability","id":"CVE-2017-12622"},"products":["Apache NiFi"],"published":"2017-10-10","related":[{"cvss_score":9.8,"headline":"Improper Restriction of XML External Entity Reference in Apache NiFi","id":"CVE-2018-1309","kev_date_added":null,"published":"2018-05-23"},{"cvss_score":9.8,"headline":"Apache NiFi XSS issue in context path handling","id":"CVE-2017-15697","kev_date_added":null,"published":"2018-01-23"},{"cvss_score":9.8,"headline":"Injection in Apache NiFi","id":"CVE-2017-5636","kev_date_added":null,"published":"2017-10-19"},{"cvss_score":8.8,"headline":"Apache NiFi: Uncontrolled Resource Consumption through Decompression of HTTP Requests","id":"CVE-2026-68981","kev_date_added":null,"published":"2026-08-03"},{"cvss_score":8.8,"headline":"Apache NiFi: Potential Code Injection with Properties Referencing Remote Resources","id":"CVE-2023-36542","kev_date_added":null,"published":"2023-07-29"},{"cvss_score":8.8,"headline":"Apache NiFi: Potential Code Injection with Database Services using H2","id":"CVE-2023-34468","kev_date_added":null,"published":"2023-06-12"},{"cvss_score":8.8,"headline":"Improper Neutralization of Command Elements in Shell User Group Provider","id":"CVE-2022-33140","kev_date_added":null,"published":"2022-06-15"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-16","vendors":["Apache Software Foundation"]},"summary":"An authorized user can exploit an XML External Entity vulnerability in Apache NiFi to access sensitive files via malicious templates.","url":"https://insights.sbomify.com/CVE-2017-12623/"}