CVE-2017-12625 Moderate severity vulnerability that affects org.apache.hive:hive, org.apache.hive:hive-exec, and org.apache.hive:hive-service
Apache Hive fails to enforce masking policies on views, allowing attackers to read sensitive data that should be masked.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2017-12625?
CVE-2017-12625 is a medium-severity vulnerability in Apache Hive, published on 1 Nov 2017. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Apache Hive 2.1.x before 2.1.2, 2.2.x before 2.2.1, and 2.3.x before 2.3.1 expose an interface through which masking policies can be defined on tables or views, e.g., using Apache Ranger. When a view is created over a given table, the policy enforcement does not happen correctly on the table for masked columns.
Weakness: CWE-200
Which versions are affected by CVE-2017-12625?
18 open source packages ship an affected version, including org.apache.hive:hive, org.apache.hive:hive-exec and org.apache.hive:hive-service. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
org.apache.hive:hive Maven | From 2.1.0 | 2.1.2 |
org.apache.hive:hive Maven | From 2.1.0 | 2.1.2 |
org.apache.hive:hive Maven | From 2.2.0 | 2.2.1 |
org.apache.hive:hive Maven | From 2.2.0 | 2.2.1 |
org.apache.hive:hive Maven | From 2.3.0 | 2.3.1 |
org.apache.hive:hive Maven | From 2.3.0 | 2.3.1 |
12 more packages
org.apache.hive:hive-exec Maven | From 2.1.0 | 2.1.2 |
org.apache.hive:hive-exec Maven | From 2.1.0 | 2.1.2 |
org.apache.hive:hive-exec Maven | From 2.2.0 | 2.2.1 |
org.apache.hive:hive-exec Maven | From 2.2.0 | 2.2.1 |
org.apache.hive:hive-exec Maven | From 2.3.0 | 2.3.1 |
org.apache.hive:hive-exec Maven | From 2.3.0 | 2.3.1 |
org.apache.hive:hive-service Maven | From 2.1.0 | 2.1.2 |
org.apache.hive:hive-service Maven | From 2.1.0 | 2.1.2 |
org.apache.hive:hive-service Maven | From 2.2.0 | 2.2.1 |
org.apache.hive:hive-service Maven | From 2.2.0 | 2.2.1 |
org.apache.hive:hive-service Maven | From 2.3.0 | 2.3.1 |
org.apache.hive:hive-service Maven | From 2.3.0 | 2.3.1 |
Products include Apache Hive.
How do I fix CVE-2017-12625?
Upgrade org.apache.hive:hive to a fixed version for your release line: 2.1.2, 2.2.1 or 2.3.1.
Is CVE-2017-12625 being exploited?
There is no known exploitation of CVE-2017-12625 in the wild and no public exploit code.
Other vulnerabilities in Apache Hive
- CVE-2026-49845 Apache Hive: SQL Injection vulnerability in HiveMetaStore partition-name direct-SQL paths
- CVE-2018-21234 Deserialization of Untrusted Data in Jodd
- CVE-2026-55976 Apache Hive: SSRF vulnerability in Hive Avro Serde due to Insufficient input validation on avro.schema.url
- CVE-2018-1282 SQL Injection in hive-jdbc
- CVE-2022-41137 Apache Hive: Deserialization of untrusted data when fetching partitions from the Metastore
Sources
Also known as GHSA-2g9q-chq2-w8qw.