# CVE-2017-12625: Moderate severity vulnerability that affects org.apache.hive:hive, org.apache.hive:hive-exec, and org.apache.hive:hive-service

> Apache Hive fails to enforce masking policies on views, allowing attackers to read sensitive data that should be masked.

- **Severity:** Medium 4.3 (`CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 Nov 2017
- **Updated:** 16 Sep 2024
- **Also known as:** GHSA-2g9q-chq2-w8qw

## What is CVE-2017-12625?

CVE-2017-12625 is a medium-severity vulnerability in Apache Hive, published on 1 Nov 2017. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Apache Hive 2.1.x before 2.1.2, 2.2.x before 2.2.1, and 2.3.x before 2.3.1 expose an interface through which masking policies can be defined on tables or views, e.g., using Apache Ranger. When a view is created over a given table, the policy enforcement does not happen correctly on the table for masked columns.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2017-12625?

18 open source packages ship an affected version, including org.apache.hive:hive, org.apache.hive:hive-exec and org.apache.hive:hive-service. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.hive:hive` | Maven | From 2.1.0 | 2.1.2 |
| `org.apache.hive:hive` | Maven | From 2.1.0 | 2.1.2 |
| `org.apache.hive:hive` | Maven | From 2.2.0 | 2.2.1 |
| `org.apache.hive:hive` | Maven | From 2.2.0 | 2.2.1 |
| `org.apache.hive:hive` | Maven | From 2.3.0 | 2.3.1 |
| `org.apache.hive:hive` | Maven | From 2.3.0 | 2.3.1 |
| `org.apache.hive:hive-exec` | Maven | From 2.1.0 | 2.1.2 |
| `org.apache.hive:hive-exec` | Maven | From 2.1.0 | 2.1.2 |
| `org.apache.hive:hive-exec` | Maven | From 2.2.0 | 2.2.1 |
| `org.apache.hive:hive-exec` | Maven | From 2.2.0 | 2.2.1 |
| `org.apache.hive:hive-exec` | Maven | From 2.3.0 | 2.3.1 |
| `org.apache.hive:hive-exec` | Maven | From 2.3.0 | 2.3.1 |
| `org.apache.hive:hive-service` | Maven | From 2.1.0 | 2.1.2 |
| `org.apache.hive:hive-service` | Maven | From 2.1.0 | 2.1.2 |
| `org.apache.hive:hive-service` | Maven | From 2.2.0 | 2.2.1 |
| `org.apache.hive:hive-service` | Maven | From 2.2.0 | 2.2.1 |
| `org.apache.hive:hive-service` | Maven | From 2.3.0 | 2.3.1 |
| `org.apache.hive:hive-service` | Maven | From 2.3.0 | 2.3.1 |

Products: Apache Hive.

## How do I fix CVE-2017-12625?

Upgrade org.apache.hive:hive to a fixed version for your release line: 2.1.2, 2.2.1 or 2.3.1.

## Is CVE-2017-12625 being exploited?

There is no known exploitation of CVE-2017-12625 in the wild and no public exploit code.

## Other vulnerabilities in Apache Hive

- [CVE-2026-49845](https://insights.sbomify.com/CVE-2026-49845/): Apache Hive: SQL Injection vulnerability in HiveMetaStore partition-name direct-SQL paths (critical 9.8)
- [CVE-2018-21234](https://insights.sbomify.com/CVE-2018-21234/): Deserialization of Untrusted Data in Jodd (critical 9.8)
- [CVE-2026-55976](https://insights.sbomify.com/CVE-2026-55976/): Apache Hive: SSRF vulnerability in Hive Avro Serde due to Insufficient input validation on avro.schema.url (critical 9.1)
- [CVE-2018-1282](https://insights.sbomify.com/CVE-2018-1282/): SQL Injection in hive-jdbc (critical 9.1)
- [CVE-2022-41137](https://insights.sbomify.com/CVE-2022-41137/): Apache Hive: Deserialization of untrusted data when fetching partitions from the Metastore (high 8.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-12625 and fix it if it is affected.

What it is: CVE-2017-12625 is a medium-severity vulnerability in Apache Hive, published on 1 Nov 2017. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2017-12625 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.hive:hive (Maven): affected from 2.1.0; fixed in 2.1.2
- org.apache.hive:hive (Maven): affected from 2.1.0; fixed in 2.1.2
- org.apache.hive:hive (Maven): affected from 2.2.0; fixed in 2.2.1
- org.apache.hive:hive (Maven): affected from 2.2.0; fixed in 2.2.1
- org.apache.hive:hive (Maven): affected from 2.3.0; fixed in 2.3.1
- org.apache.hive:hive (Maven): affected from 2.3.0; fixed in 2.3.1
- org.apache.hive:hive-exec (Maven): affected from 2.1.0; fixed in 2.1.2
- org.apache.hive:hive-exec (Maven): affected from 2.1.0; fixed in 2.1.2
- org.apache.hive:hive-exec (Maven): affected from 2.2.0; fixed in 2.2.1
- org.apache.hive:hive-exec (Maven): affected from 2.2.0; fixed in 2.2.1
- org.apache.hive:hive-exec (Maven): affected from 2.3.0; fixed in 2.3.1
- org.apache.hive:hive-exec (Maven): affected from 2.3.0; fixed in 2.3.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-12625/ (Markdown: https://insights.sbomify.com/CVE-2017-12625/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-12625
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-12625
- OSV: https://osv.dev/vulnerability/CVE-2017-12625

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-12625/
Summaries are generated and may contain mistakes; the official description above is the record.
