{"answers":{"affected":"2 open source packages ship an affected version, including org.apache.poi:poi. It affects 1 product.","exploited":"There is no known exploitation of CVE-2017-12626 in the wild and no public exploit code.","fix":"Upgrade org.apache.poi:poi to 3.17 or later.","what":"CVE-2017-12626 is a high-severity denial of service vulnerability in Apache POI, published on 29 Jan 2018. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2017-12626 and fix it if it is affected.\n\nWhat it is: CVE-2017-12626 is a high-severity denial of service vulnerability in Apache POI, published on 29 Jan 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2017-12626 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.apache.poi:poi (Maven): affected all versions; fixed in 3.17\n- org.apache.poi:poi (Maven): affected all versions; fixed in 3.17\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2017-12626/ (Markdown: https://insights.sbomify.com/CVE-2017-12626/index.md)","id":"CVE-2017-12626","markdown":"https://insights.sbomify.com/CVE-2017-12626/index.md","name":"CVE-2017-12626","record":{"aliases":["CLSA-2026-1782435542","DEBIAN-CVE-2017-12626","GHSA-523c-xh4g-mh5m","UBUNTU-CVE-2017-12626"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Java Office document library","requires_auth":"none","summary":"Attackers can cause denial of service via infinite loops or out-of-memory errors by crafting malicious Office documents parsed by Apache POI.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"apache","cpe":[{"product":"poi","vendor":"apache"}],"cvss":{"score":7.5,"severity":"high","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-835","name":"Loop with Unreachable Exit Condition"}],"description":"Apache POI in versions prior to release 3.17 are vulnerable to Denial of Service Attacks: 1) Infinite Loops while parsing crafted WMF, EMF, MSG and macros (POI bugs 61338 and 61294), and 2) Out of Memory Exceptions while parsing crafted DOC, PPT and XLS (POI bugs 52372 and 61295).","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Denial of Service in Apache POI","id":"CVE-2017-12626","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"denial_of_service","year":"2017"},"n_packages":2,"n_references":11,"next":{"headline":"Null dereference in Apache Xerces C++","id":"CVE-2017-12627"},"packages":[{"ecosystem":"Maven","fixed":["3.17"],"introduced":["0"],"last_affected":[],"package":"org.apache.poi:poi","purl":null,"source":"GHSA-523c-xh4g-mh5m"},{"ecosystem":"Maven","fixed":["3.17"],"introduced":["0"],"last_affected":[],"package":"org.apache.poi:poi","purl":"pkg:maven/org.apache.poi/poi","source":"GHSA-523c-xh4g-mh5m"}],"prev":{"headline":"Moderate severity vulnerability that affects org.apache.hive:hive, org.apache.hive:hive-exec, and org.apache.hive:hive-service","id":"CVE-2017-12625"},"products":["Apache POI"],"published":"2018-01-29","related":[{"cvss_score":5.5,"headline":"A carefully crafted TNEF file can cause an out of memory exception","id":"CVE-2022-26336","kev_date_added":null,"published":"2022-03-04"},{"cvss_score":5.5,"headline":"Improper Restriction of XML External Entity Reference in Apache POI","id":"CVE-2019-12415","kev_date_added":null,"published":"2019-10-23"},{"cvss_score":5.5,"headline":"Improper Restriction of Recursive Entity References in DTDs in Apache POI","id":"CVE-2017-5644","kev_date_added":null,"published":"2017-03-24"},{"cvss_score":5.5,"headline":"Apache POI's XLSX2CSV Example XML External Entity (XXE) Vulnerability","id":"CVE-2016-5000","kev_date_added":null,"published":"2016-08-05"},{"cvss_score":5.3,"headline":"Apache POI OOXML Vulnerable to Improper Input Validation in OOXML File Parsing","id":"CVE-2025-31672","kev_date_added":null,"published":"2025-04-09"},{"cvss_score":5,"headline":"Loop with Unreachable Exit Condition in Apache POI","id":"CVE-2014-9527","kev_date_added":null,"published":"2015-01-06"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-05-28","vendors":["Apache Software Foundation"]},"summary":"Attackers can cause denial of service via infinite loops or out-of-memory errors by crafting malicious Office documents parsed by Apache POI.","url":"https://insights.sbomify.com/CVE-2017-12626/"}