# CVE-2017-12626: Denial of Service in Apache POI

> Attackers can cause denial of service via infinite loops or out-of-memory errors by crafting malicious Office documents parsed by Apache POI.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 29 Jan 2018
- **Updated:** 28 May 2026
- **Also known as:** CLSA-2026-1782435542, DEBIAN-CVE-2017-12626, GHSA-523c-xh4g-mh5m, UBUNTU-CVE-2017-12626

## What is CVE-2017-12626?

CVE-2017-12626 is a high-severity denial of service vulnerability in Apache POI, published on 29 Jan 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Apache POI in versions prior to release 3.17 are vulnerable to Denial of Service Attacks: 1) Infinite Loops while parsing crafted WMF, EMF, MSG and macros (POI bugs 61338 and 61294), and 2) Out of Memory Exceptions while parsing crafted DOC, PPT and XLS (POI bugs 52372 and 61295).

Weakness: CWE-835 (Loop with Unreachable Exit Condition)

## Which versions are affected by CVE-2017-12626?

2 open source packages ship an affected version, including org.apache.poi:poi. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.poi:poi` | Maven | All versions | 3.17 |
| `org.apache.poi:poi` | Maven | All versions | 3.17 |

Products: Apache Poi.

## How do I fix CVE-2017-12626?

Upgrade org.apache.poi:poi to 3.17 or later.

## Is CVE-2017-12626 being exploited?

There is no known exploitation of CVE-2017-12626 in the wild and no public exploit code.

## Other vulnerabilities in Apache POI

- [CVE-2022-26336](https://insights.sbomify.com/CVE-2022-26336/): A carefully crafted TNEF file can cause an out of memory exception (medium 5.5)
- [CVE-2019-12415](https://insights.sbomify.com/CVE-2019-12415/): Improper Restriction of XML External Entity Reference in Apache POI (medium 5.5)
- [CVE-2017-5644](https://insights.sbomify.com/CVE-2017-5644/): Improper Restriction of Recursive Entity References in DTDs in Apache POI (medium 5.5)
- [CVE-2016-5000](https://insights.sbomify.com/CVE-2016-5000/): Apache POI's XLSX2CSV Example XML External Entity (XXE) Vulnerability (medium 5.5)
- [CVE-2025-31672](https://insights.sbomify.com/CVE-2025-31672/): Apache POI OOXML Vulnerable to Improper Input Validation in OOXML File Parsing (medium 5.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-12626 and fix it if it is affected.

What it is: CVE-2017-12626 is a high-severity denial of service vulnerability in Apache POI, published on 29 Jan 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2017-12626 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.poi:poi (Maven): affected all versions; fixed in 3.17
- org.apache.poi:poi (Maven): affected all versions; fixed in 3.17

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-12626/ (Markdown: https://insights.sbomify.com/CVE-2017-12626/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-12626
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-12626
- OSV: https://osv.dev/vulnerability/CVE-2017-12626

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-12626/
Summaries are generated and may contain mistakes; the official description above is the record.
