CVE-2017-12631 Moderate severity vulnerability that affects org.apache.cxf.fediz:fediz-spring, org.apache.cxf.fediz:fediz-spring2, and org.apache.cxf.fediz:fediz-spring3
A CSRF vulnerability in Apache CXF Fediz Spring plugins allows attackers to manipulate user security contexts and roles.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2017-12631?
CVE-2017-12631 is a high-severity vulnerability in Apache CXF Fediz, published on 30 Nov 2017. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
Apache CXF Fediz ships with a number of container-specific plugins to enable WS-Federation for applications. A CSRF (Cross Style Request Forgery) style vulnerability has been found in the Spring 2, Spring 3 and Spring 4 plugins in versions before 1.4.3 and 1.3.3. The vulnerability can result in a security context that is set up using a malicious client's roles for the given enduser.
Weakness: CWE-352
Which versions are affected by CVE-2017-12631?
12 open source packages ship an affected version, including org.apache.cxf.fediz:fediz-spring, org.apache.cxf.fediz:fediz-spring2 and org.apache.cxf.fediz:fediz-spring3. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
org.apache.cxf.fediz:fediz-spring Maven | All versions | 1.3.3 |
org.apache.cxf.fediz:fediz-spring Maven | All versions | 1.3.3 |
org.apache.cxf.fediz:fediz-spring Maven | From 1.4.0 | 1.4.3 |
org.apache.cxf.fediz:fediz-spring Maven | From 1.4.0 | 1.4.3 |
org.apache.cxf.fediz:fediz-spring2 Maven | All versions | 1.3.3 |
org.apache.cxf.fediz:fediz-spring2 Maven | All versions | 1.3.3 |
6 more packages
org.apache.cxf.fediz:fediz-spring2 Maven | From 1.4.0 | 1.4.3 |
org.apache.cxf.fediz:fediz-spring2 Maven | From 1.4.0 | 1.4.3 |
org.apache.cxf.fediz:fediz-spring3 Maven | All versions | 1.3.3 |
org.apache.cxf.fediz:fediz-spring3 Maven | All versions | 1.3.3 |
org.apache.cxf.fediz:fediz-spring3 Maven | From 1.4.0 | 1.4.3 |
org.apache.cxf.fediz:fediz-spring3 Maven | From 1.4.0 | 1.4.3 |
Products include Apache Cxf Fediz.
How do I fix CVE-2017-12631?
Upgrade org.apache.cxf.fediz:fediz-spring to a fixed version for your release line: 1.3.3 or 1.4.3.
Is CVE-2017-12631 being exploited?
There is no known exploitation of CVE-2017-12631 in the wild and no public exploit code.
Other vulnerabilities in Apache CXF Fediz
- CVE-2016-4464 High severity vulnerability that affects org.apache.cxf.fediz:fediz-spring and org.apache.cxf.fediz:fediz-spring2
- CVE-2017-7661 Moderate severity vulnerability that affects org.apache.cxf.fediz:fediz-jetty8, org.apache.cxf.fediz:fediz-jetty9, and org.apache.cxf.fediz:fediz-spring2
- CVE-2017-7662 Cross-Site Request Forgery in Apache CXF Fediz
- CVE-2018-8038 High severity vulnerability that affects org.apache.cxf.fediz:fediz-jetty8, org.apache.cxf.fediz:fediz-jetty9, org.apache.cxf.fediz:fediz-spring, org.apache.cxf.fediz:fediz-spring2, and org.apache.cxf.fediz:fediz-spring3
- CVE-2015-5175 Apache CXF Fediz application plugins are vulnerable to Denial of Service (DoS) attacks
Sources
Also known as GHSA-fv7x-4hpc-hf9f.