# CVE-2017-12646: Liferay Portal XSS Vulnerability

> Cross-site scripting in Liferay Portal allows attackers to inject scripts via login credentials, potentially leading to session hijacking or code execution.

- **Severity:** Medium 6.1 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 7 Aug 2017
- **Updated:** 16 Sep 2024
- **Also known as:** GHSA-8gqf-26xw-x3gx

## What is CVE-2017-12646?

CVE-2017-12646 is a medium-severity cross-site scripting vulnerability in Liferay Liferay Portal, published on 7 Aug 2017. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

XSS exists in Liferay Portal before 7.0 CE GA4 via a login name, password, or e-mail address.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2017-12646?

6 open source packages ship an affected version, including com.liferay.portal:release.portal.bom, com.liferay:com.liferay.login.authentication.openid.connect.web and com.liferay:com.liferay.login.web. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `com.liferay.portal:release.portal.bom` | Maven | All versions | 7.0.3-GA4 |
| `com.liferay.portal:release.portal.bom` | Maven | All versions | 7.0.3-GA4 |
| `com.liferay:com.liferay.login.authentication.openid.connect.web` | Maven | From 1.0.0 | 1.0.1 |
| `com.liferay:com.liferay.login.authentication.openid.connect.web` | Maven | From 1.0.0 | 1.0.1 |
| `com.liferay:com.liferay.login.web` | Maven | All versions | 1.1.20 |
| `com.liferay:com.liferay.login.web` | Maven | All versions | 1.1.20 |

Products: Liferay Liferay Portal.

## How do I fix CVE-2017-12646?

Upgrade com.liferay.portal:release.portal.bom to 7.0.3-GA4 or later.

## Is CVE-2017-12646 being exploited?

There is no known exploitation of CVE-2017-12646 in the wild and no public exploit code.

## Other vulnerabilities in Liferay Liferay Portal

- [CVE-2020-7961](https://insights.sbomify.com/CVE-2020-7961/): Liferay Portal Deserialization of Untrusted Data (critical 9.8, exploited in the wild)
- [CVE-2021-33990](https://insights.sbomify.com/CVE-2021-33990/): File upload in n/a (critical 9.8)
- [CVE-2019-16891](https://insights.sbomify.com/CVE-2019-16891/): Liferay Portal Allows RCE via Deserialization of a JSON Payload (critical 9.8)
- [CVE-2023-47797](https://insights.sbomify.com/CVE-2023-47797/): Liferay Portal XSS with `p_l_back_url_title` on edit content page (critical 9.6)
- [CVE-2020-13445](https://insights.sbomify.com/CVE-2020-13445/): Liferay Portal and Liferay DXP Vulnerable to Arbitrary Code Execution (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-12646 and fix it if it is affected.

What it is: CVE-2017-12646 is a medium-severity cross-site scripting vulnerability in Liferay Liferay Portal, published on 7 Aug 2017. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2017-12646 in the wild and no public exploit code.

Affected packages and fixed versions:
- com.liferay.portal:release.portal.bom (Maven): affected all versions; fixed in 7.0.3-GA4
- com.liferay.portal:release.portal.bom (Maven): affected all versions; fixed in 7.0.3-GA4
- com.liferay:com.liferay.login.authentication.openid.connect.web (Maven): affected from 1.0.0; fixed in 1.0.1
- com.liferay:com.liferay.login.authentication.openid.connect.web (Maven): affected from 1.0.0; fixed in 1.0.1
- com.liferay:com.liferay.login.web (Maven): affected all versions; fixed in 1.1.20
- com.liferay:com.liferay.login.web (Maven): affected all versions; fixed in 1.1.20

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-12646/ (Markdown: https://insights.sbomify.com/CVE-2017-12646/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-12646
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-12646
- OSV: https://osv.dev/vulnerability/CVE-2017-12646

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-12646/
Summaries are generated and may contain mistakes; the official description above is the record.
