# CVE-2017-12791: SaltStack Salt Directory traversal vulnerability in minion id validation

> Remote attackers can bypass authentication and gain unauthorized access to the Salt master by exploiting a directory traversal flaw in minion ID validation.

- **Severity:** Critical 9.8 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 23 Aug 2017
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-xxvj-8g5m-4qgw, PYSEC-2017-35, SUSE-SU-2017:2666-1, SUSE-SU-2017:2674-1, SUSE-SU-2017:2676-1, UBUNTU-CVE-2017-12791

## What is CVE-2017-12791?

CVE-2017-12791 is a critical path traversal vulnerability in Saltstack Salt, published on 23 Aug 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Directory traversal vulnerability in minion id validation in SaltStack Salt before 2016.11.7 and 2017.7.x before 2017.7.1 allows remote minions with incorrect credentials to authenticate to a master via a crafted minion ID.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2017-12791?

5 open source packages ship an affected version, including salt. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `salt` | PyPI | All versions | 2016.11.7, 2017.7.1 |
| `salt` | PyPI | All versions | 2016.11.7 |
| `salt` | PyPI | All versions | 2016.11.7 |
| `salt` | PyPI | From 2017.7.0 | 2017.7.1 |
| `salt` | PyPI | From 2017.7.0 | 2017.7.1 |
| `salt` | SUSE:Enterprise Storage 3 | All versions | 2016.11.4-46.7.1 |
| `salt` | SUSE:Enterprise Storage 4 | All versions | 2016.11.4-46.7.1 |
| `salt` | SUSE:Linux Enterprise Module for Advanced Systems Management 12 | All versions | 2016.11.4-46.7.1 |
| `salt` | SUSE:Linux Enterprise Point of Sale 12 SP2 | All versions | 2016.11.4-46.7.1 |
| `salt` | SUSE:Linux Enterprise Server 11 SP3-CLIENT-TOOLS | All versions | 2016.11.4-43.7.1 |
| `salt` | SUSE:Linux Enterprise Server 11 SP4-CLIENT-TOOLS | All versions | 2016.11.4-43.7.1 |
| `salt` | SUSE:Manager Client Tools 12 | All versions | 2016.11.4-46.7.1 |
| `salt` | SUSE:Manager Proxy 3.0 | All versions | 2016.11.4-46.7.1 |
| `salt` | SUSE:Manager Proxy 3.1 | All versions | 2016.11.4-4.3.1 |
| `salt` | SUSE:Manager Server 3.0 | All versions | 2016.11.4-46.7.1 |
| `salt` | SUSE:Manager Server 3.1 | All versions | 2016.11.4-4.3.1 |

Products: Saltstack Salt.

## How do I fix CVE-2017-12791?

Upgrade salt to a fixed version for your release line: 2016.11.7 or 2017.7.1.

## Is CVE-2017-12791 being exploited?

There is no known exploitation of CVE-2017-12791 in the wild and no public exploit code.

## Other vulnerabilities in Saltstack Salt

- [CVE-2013-4437](https://insights.sbomify.com/CVE-2013-4437/): SaltStack insecurely uses /tmp (critical 10.0)
- [CVE-2013-6617](https://insights.sbomify.com/CVE-2013-6617/): SaltStack Privilege Escalation vulnerability (critical 10.0)
- [CVE-2021-33226](https://insights.sbomify.com/CVE-2021-33226/): Code injection in n/a (critical 9.8)
- [CVE-2021-25315](https://insights.sbomify.com/CVE-2021-25315/): salt-api unauthenticated remote code execution (critical 9.8)
- [CVE-2018-15751](https://insights.sbomify.com/CVE-2018-15751/): SaltStack Salt Remote command execution and incorrect access control when using salt-api (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-12791 and fix it if it is affected.

What it is: CVE-2017-12791 is a critical path traversal vulnerability in Saltstack Salt, published on 23 Aug 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2017-12791 in the wild and no public exploit code.

Affected packages and fixed versions:
- salt (PyPI): affected all versions; fixed in 2016.11.7, 2017.7.1
- salt (PyPI): affected all versions; fixed in 2016.11.7
- salt (PyPI): affected all versions; fixed in 2016.11.7
- salt (PyPI): affected from 2017.7.0; fixed in 2017.7.1
- salt (PyPI): affected from 2017.7.0; fixed in 2017.7.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-12791/ (Markdown: https://insights.sbomify.com/CVE-2017-12791/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-12791
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-12791
- OSV: https://osv.dev/vulnerability/CVE-2017-12791

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-12791/
Summaries are generated and may contain mistakes; the official description above is the record.
