# CVE-2017-12794: Django vulnerable to XSS on 500 pages

> Cross-site scripting in Django's debug page allows attackers to execute scripts if DEBUG mode is enabled in production.

- **Severity:** Medium 6.1 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 7 Sep 2017
- **Updated:** 5 Aug 2024
- **Also known as:** ALPINE-CVE-2017-12794, DEBIAN-CVE-2017-12794, GHSA-9r8w-6x8c-6jr9, PYSEC-2017-44

## What is CVE-2017-12794?

CVE-2017-12794 is a medium-severity cross-site scripting vulnerability in Djangoproject Django, published on 7 Sep 2017. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

In Django 1.10.x before 1.10.8 and 1.11.x before 1.11.5, HTML autoescaping was disabled in a portion of the template for the technical 500 debug page. Given the right circumstances, this allowed a cross-site scripting attack. This vulnerability shouldn't affect most production sites since you shouldn't run with "DEBUG = True" (which makes this page accessible) in your production settings.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2017-12794?

5 open source packages ship an affected version, including django and Django. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `django` | PyPI | From 1.10 | 1.10.8, 1.11.5 |
| `django` | PyPI | From 1.10a1 | 1.10.8 |
| `django` | PyPI | From 1.11a1 | 1.11.5 |
| `Django` | PyPI | From 1.10a1 | 1.10.8 |
| `Django` | PyPI | From 1.11a1 | 1.11.5 |

Products: Djangoproject Django.

## How do I fix CVE-2017-12794?

Upgrade django to a fixed version for your release line: 1.10.8 or 1.11.5.

## Is CVE-2017-12794 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2017-12794 exists.

Public exploit code:

- Django Debug Page - Cross-Site Scripting (nuclei): http/cves/2017/CVE-2017-12794.yaml

## Other vulnerabilities in Djangoproject Django

- [CVE-2026-4277](https://insights.sbomify.com/CVE-2026-4277/): Privilege abuse in GenericInlineModelAdmin (critical 9.8)
- [CVE-2024-53908](https://insights.sbomify.com/CVE-2024-53908/): Django SQL injection in HasKey(lhs, rhs) on Oracle (critical 9.8)
- [CVE-2024-42005](https://insights.sbomify.com/CVE-2024-42005/): Django SQL injection vulnerability (critical 9.8)
- [CVE-2023-31047](https://insights.sbomify.com/CVE-2023-31047/): Django bypasses validation when using one form field to upload multiple files (critical 9.8)
- [CVE-2022-34265](https://insights.sbomify.com/CVE-2022-34265/): Django `Trunc()` and `Extract()` database functions vulnerable to SQL Injection (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-12794 and fix it if it is affected.

What it is: CVE-2017-12794 is a medium-severity cross-site scripting vulnerability in Djangoproject Django, published on 7 Sep 2017. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2017-12794 exists.

Affected packages and fixed versions:
- django (PyPI): affected from 1.10; fixed in 1.10.8, 1.11.5
- django (PyPI): affected from 1.10a1; fixed in 1.10.8
- django (PyPI): affected from 1.11a1; fixed in 1.11.5
- Django (PyPI): affected from 1.10a1; fixed in 1.10.8
- Django (PyPI): affected from 1.11a1; fixed in 1.11.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-12794/ (Markdown: https://insights.sbomify.com/CVE-2017-12794/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-12794
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-12794
- OSV: https://osv.dev/vulnerability/CVE-2017-12794

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-12794/
Summaries are generated and may contain mistakes; the official description above is the record.
