# CVE-2017-12862: Improper Restriction of Operations within the Bounds of a Memory Buffer in OpenCV

> A buffer overflow in OpenCV's PXM image parser allows remote attackers to execute arbitrary code or cause denial of service via crafted images.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 15 Aug 2017
- **Updated:** 5 Aug 2024
- **Also known as:** DEBIAN-CVE-2017-12862, GHSA-5rpc-gwh9-q9fg, PYSEC-2026-2807, PYSEC-2026-699, UBUNTU-CVE-2017-12862

## What is CVE-2017-12862?

CVE-2017-12862 is a high-severity memory corruption vulnerability in Debian Debian Linux, published on 15 Aug 2017. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

In modules/imgcodecs/src/grfmt_pxm.cpp, the length of buffer AutoBuffer _src is small than expected, which will cause copy buffer overflow later. If the image is from remote, may lead to remote code execution or denial of service. This affects Opencv 3.3 and earlier.

Weakness: CWE-787 (Out-of-bounds Write)

## Which versions are affected by CVE-2017-12862?

6 open source packages ship an affected version, including opencv-contrib-python and opencv-python. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `opencv-contrib-python` | PyPI | All versions | 3.3.1.11 |
| `opencv-contrib-python` | PyPI | All versions | 3.3.1.11 |
| `opencv-contrib-python` | PyPI | All versions | 3.3.1.11 |
| `opencv-python` | PyPI | All versions | 3.3.1.11 |
| `opencv-python` | PyPI | All versions | 3.3.1.11 |
| `opencv-python` | PyPI | All versions | 3.3.1.11 |

Products: Debian Debian Linux, Opencv Opencv.

## How do I fix CVE-2017-12862?

Upgrade opencv-contrib-python to 3.3.1.11 or later.

## Is CVE-2017-12862 being exploited?

There is no known exploitation of CVE-2017-12862 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-12862 and fix it if it is affected.

What it is: CVE-2017-12862 is a high-severity memory corruption vulnerability in Debian Debian Linux, published on 15 Aug 2017. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2017-12862 in the wild and no public exploit code.

Affected packages and fixed versions:
- opencv-contrib-python (PyPI): affected all versions; fixed in 3.3.1.11
- opencv-contrib-python (PyPI): affected all versions; fixed in 3.3.1.11
- opencv-contrib-python (PyPI): affected all versions; fixed in 3.3.1.11
- opencv-python (PyPI): affected all versions; fixed in 3.3.1.11
- opencv-python (PyPI): affected all versions; fixed in 3.3.1.11
- opencv-python (PyPI): affected all versions; fixed in 3.3.1.11

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-12862/ (Markdown: https://insights.sbomify.com/CVE-2017-12862/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-12862
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-12862
- OSV: https://osv.dev/vulnerability/CVE-2017-12862

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-12862/
Summaries are generated and may contain mistakes; the official description above is the record.
