# CVE-2017-12867: SimpleSAMLphp Invalid token creation and validation

> Attackers with a secret token can extend its validity by manipulating time offsets, bypassing expiration controls in SimpleSAMLphp.

- **Severity:** Medium 5.9 (`CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 29 Aug 2017
- **Updated:** 5 Aug 2024
- **Also known as:** DEBIAN-CVE-2017-12867, GHSA-597c-mh7m-48v7, UBUNTU-CVE-2017-12867

## What is CVE-2017-12867?

CVE-2017-12867 is a medium-severity vulnerability in n/a, published on 29 Aug 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The SimpleSAML_Auth_TimeLimitedToken class in SimpleSAMLphp 1.14.14 and earlier allows attackers with access to a secret token to extend its validity period by manipulating the prepended time offset.

Weakness: CWE-613 (DEPRECATED: Insufficient Session Expiration)

## Which versions are affected by CVE-2017-12867?

2 open source packages ship an affected version, including simplesamlphp/simplesamlphp. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `simplesamlphp/simplesamlphp` | Packagist | From 1.14.0 | 1.14.15 |
| `simplesamlphp/simplesamlphp` | Packagist | From 1.14.0 | 1.14.15 |

Products: Simplesamlphp Simplesamlphp.

## How do I fix CVE-2017-12867?

Upgrade simplesamlphp/simplesamlphp to 1.14.15 or later.

## Is CVE-2017-12867 being exploited?

There is no known exploitation of CVE-2017-12867 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2017-12868](https://insights.sbomify.com/CVE-2017-12868/): SimpleSAMLphp Session fixation issue and authentication bypass in the authcrypt module (critical 9.8)
- [CVE-2018-7644](https://insights.sbomify.com/CVE-2018-7644/): SimpleSAMLphp Improper Verification of Cryptographic Signature (high 7.5)
- [CVE-2026-49284](https://insights.sbomify.com/CVE-2026-49284/): SimpleSAMLphp SP accepts a response from an unexpected IdP when unsigned `Response/InResponseTo` is combined with a signed assertion lacking `SubjectConfirmationData/InResponseTo` (high 7.1)
- [CVE-2018-6520](https://insights.sbomify.com/CVE-2018-6520/): SimpleSAMLphp Open redirection protection bypass (medium 6.1)
- [CVE-2017-12870](https://insights.sbomify.com/CVE-2017-12870/): SimpleSAMLphp Unauthenticated encryption in CBC mode (medium 5.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-12867 and fix it if it is affected.

What it is: CVE-2017-12867 is a medium-severity vulnerability in n/a, published on 29 Aug 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2017-12867 in the wild and no public exploit code.

Affected packages and fixed versions:
- simplesamlphp/simplesamlphp (Packagist): affected from 1.14.0; fixed in 1.14.15
- simplesamlphp/simplesamlphp (Packagist): affected from 1.14.0; fixed in 1.14.15

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-12867/ (Markdown: https://insights.sbomify.com/CVE-2017-12867/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-12867
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-12867
- OSV: https://osv.dev/vulnerability/CVE-2017-12867

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-12867/
Summaries are generated and may contain mistakes; the official description above is the record.
