# CVE-2017-12868: SimpleSAMLphp Session fixation issue and authentication bypass in the authcrypt module

> Attackers can bypass authentication or fixate sessions in SimpleSAMLphp due to flawed cryptographic comparison logic in older PHP versions.

- **Severity:** Critical 9.8 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 Sep 2017
- **Updated:** 5 Aug 2024
- **Also known as:** DEBIAN-CVE-2017-12868, GHSA-j96g-47x2-46hv, UBUNTU-CVE-2017-12868

## What is CVE-2017-12868?

CVE-2017-12868 is a critical authentication bypass vulnerability in n/a, published on 1 Sep 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The secureCompare method in lib/SimpleSAML/Utils/Crypto.php in SimpleSAMLphp 1.14.13 and earlier, when used with PHP before 5.6, allows attackers to conduct session fixation attacks or possibly bypass authentication by leveraging missing character conversions before an XOR operation.

Weakness: CWE-384 (Session Fixation)

## Which versions are affected by CVE-2017-12868?

2 open source packages ship an affected version, including simplesamlphp/simplesamlphp. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `simplesamlphp/simplesamlphp` | Packagist | From 1.14.12 | 1.14.14 |
| `simplesamlphp/simplesamlphp` | Packagist | From 1.14.12 | 1.14.14 |

Products: Simplesamlphp Simplesamlphp.

## How do I fix CVE-2017-12868?

Upgrade simplesamlphp/simplesamlphp to 1.14.14 or later.

## Is CVE-2017-12868 being exploited?

There is no known exploitation of CVE-2017-12868 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2018-7644](https://insights.sbomify.com/CVE-2018-7644/): SimpleSAMLphp Improper Verification of Cryptographic Signature (high 7.5)
- [CVE-2026-49284](https://insights.sbomify.com/CVE-2026-49284/): SimpleSAMLphp SP accepts a response from an unexpected IdP when unsigned `Response/InResponseTo` is combined with a signed assertion lacking `SubjectConfirmationData/InResponseTo` (high 7.1)
- [CVE-2018-6520](https://insights.sbomify.com/CVE-2018-6520/): SimpleSAMLphp Open redirection protection bypass (medium 6.1)
- [CVE-2017-12870](https://insights.sbomify.com/CVE-2017-12870/): SimpleSAMLphp Unauthenticated encryption in CBC mode (medium 5.9)
- [CVE-2017-12871](https://insights.sbomify.com/CVE-2017-12871/): SimpleSAMLphp Incorrect IV generation for encryption (medium 5.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-12868 and fix it if it is affected.

What it is: CVE-2017-12868 is a critical authentication bypass vulnerability in n/a, published on 1 Sep 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2017-12868 in the wild and no public exploit code.

Affected packages and fixed versions:
- simplesamlphp/simplesamlphp (Packagist): affected from 1.14.12; fixed in 1.14.14
- simplesamlphp/simplesamlphp (Packagist): affected from 1.14.12; fixed in 1.14.14

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-12868/ (Markdown: https://insights.sbomify.com/CVE-2017-12868/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-12868
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-12868
- OSV: https://osv.dev/vulnerability/CVE-2017-12868

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-12868/
Summaries are generated and may contain mistakes; the official description above is the record.
