# CVE-2017-12870: SimpleSAMLphp Unauthenticated encryption in CBC mode

> Man-in-the-middle attackers can obtain sensitive session identifiers due to weak encryption in SimpleSAMLphp when communicating with non-HTTPS service providers.

- **Severity:** Medium 5.9 (`CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 Sep 2017
- **Updated:** 5 Aug 2024
- **Also known as:** DEBIAN-CVE-2017-12870, GHSA-44pr-mgcp-v36r, UBUNTU-CVE-2017-12870

## What is CVE-2017-12870?

CVE-2017-12870 is a medium-severity vulnerability in n/a, published on 1 Sep 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

SimpleSAMLphp 1.14.12 and earlier make it easier for man-in-the-middle attackers to obtain sensitive information by leveraging use of the aesEncrypt and aesDecrypt methods in the SimpleSAML/Utils/Crypto class to protect session identifiers in replies to non-HTTPS service providers.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2017-12870?

2 open source packages ship an affected version, including simplesamlphp/simplesamlphp. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `simplesamlphp/simplesamlphp` | Packagist | All versions | 1.14.13 |
| `simplesamlphp/simplesamlphp` | Packagist | All versions | 1.14.13 |

Products: Simplesamlphp Simplesamlphp.

## How do I fix CVE-2017-12870?

Upgrade simplesamlphp/simplesamlphp to 1.14.13 or later.

## Is CVE-2017-12870 being exploited?

There is no known exploitation of CVE-2017-12870 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2017-12868](https://insights.sbomify.com/CVE-2017-12868/): SimpleSAMLphp Session fixation issue and authentication bypass in the authcrypt module (critical 9.8)
- [CVE-2018-7644](https://insights.sbomify.com/CVE-2018-7644/): SimpleSAMLphp Improper Verification of Cryptographic Signature (high 7.5)
- [CVE-2026-49284](https://insights.sbomify.com/CVE-2026-49284/): SimpleSAMLphp SP accepts a response from an unexpected IdP when unsigned `Response/InResponseTo` is combined with a signed assertion lacking `SubjectConfirmationData/InResponseTo` (high 7.1)
- [CVE-2018-6520](https://insights.sbomify.com/CVE-2018-6520/): SimpleSAMLphp Open redirection protection bypass (medium 6.1)
- [CVE-2017-12871](https://insights.sbomify.com/CVE-2017-12871/): SimpleSAMLphp Incorrect IV generation for encryption (medium 5.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-12870 and fix it if it is affected.

What it is: CVE-2017-12870 is a medium-severity vulnerability in n/a, published on 1 Sep 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2017-12870 in the wild and no public exploit code.

Affected packages and fixed versions:
- simplesamlphp/simplesamlphp (Packagist): affected all versions; fixed in 1.14.13
- simplesamlphp/simplesamlphp (Packagist): affected all versions; fixed in 1.14.13

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-12870/ (Markdown: https://insights.sbomify.com/CVE-2017-12870/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-12870
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-12870
- OSV: https://osv.dev/vulnerability/CVE-2017-12870

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-12870/
Summaries are generated and may contain mistakes; the official description above is the record.
