{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2017-12933 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2017-12933 is a critical memory corruption vulnerability in Php Php, published on 18 Aug 2017. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2017-12933 and fix it if it is affected.\n\nWhat it is: CVE-2017-12933 is a critical memory corruption vulnerability in Php Php, published on 18 Aug 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2017-12933 in the wild and no public exploit code.\n\nAffected product: Php Php. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2017-12933/ (Markdown: https://insights.sbomify.com/CVE-2017-12933/index.md)","id":"CVE-2017-12933","markdown":"https://insights.sbomify.com/CVE-2017-12933/index.md","name":"CVE-2017-12933","record":{"aliases":["CVE-2017-1000202","DLA-1076-1","GHSA-rfjj-ch7h-pvv6","SUSE-SU-2017:2518-1","UBUNTU-CVE-2017-12933"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service","other"],"network_reachable":"yes","non_default_config":false,"product_category":"PHP core","requires_auth":"none","summary":"A buffer over-read in PHP's unserializer allows attackers to cause integrity issues or crashes when processing untrusted data.","user_interaction":"not_required","vuln_class":"memory_corruption"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"php","vendor":"php"}],"cvss":{"score":9.8,"severity":"critical","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.0"},"cwes":[{"id":"CWE-125","name":"Out-of-bounds Read"}],"description":"The finish_nested_data function in ext/standard/var_unserializer.re in PHP before 5.6.31, 7.0.x before 7.0.21, and 7.1.x before 7.1.7 is prone to a buffer over-read while unserializing untrusted data. Exploitation of this issue can have an unspecified impact on the integrity of PHP.","ecosystems":["SUSE:Linux Enterprise Module for Web and Scripting 12","SUSE:Linux Enterprise Software Development Kit 12 SP2","SUSE:Linux Enterprise Software Development Kit 12 SP3"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Memory corruption in n/a","id":"CVE-2017-12933","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":"php:php","products":["php:php"],"type":"memory_corruption","year":"2017"},"n_packages":3,"n_references":9,"next":{"headline":"Use after free in n/a","id":"CVE-2017-12934"},"packages":[{"ecosystem":"SUSE:Linux Enterprise Module for Web and Scripting 12","fixed":["5.5.14-109.8.2"],"introduced":["0"],"last_affected":[],"package":"php5","purl":"pkg:rpm/suse/php5\u0026distro=SUSE%20Linux%20Enterprise%20Module%20for%20Web%20and%20Scripting%2012","source":"SUSE-SU-2017:2518-1"},{"ecosystem":"SUSE:Linux Enterprise Software Development Kit 12 SP2","fixed":["5.5.14-109.8.2"],"introduced":["0"],"last_affected":[],"package":"php5","purl":"pkg:rpm/suse/php5\u0026distro=SUSE%20Linux%20Enterprise%20Software%20Development%20Kit%2012%20SP2","source":"SUSE-SU-2017:2518-1"},{"ecosystem":"SUSE:Linux Enterprise Software Development Kit 12 SP3","fixed":["5.5.14-109.8.2"],"introduced":["0"],"last_affected":[],"package":"php5","purl":"pkg:rpm/suse/php5\u0026distro=SUSE%20Linux%20Enterprise%20Software%20Development%20Kit%2012%20SP3","source":"SUSE-SU-2017:2518-1"}],"prev":{"headline":"Use after free in n/a","id":"CVE-2017-12932"},"products":["n/a"],"published":"2017-08-18","related":[{"cvss_score":10,"headline":"Integer overflow in n/a","id":"CVE-2012-2688","kev_date_added":null,"published":"2012-07-20"},{"cvss_score":10,"headline":"Memory corruption in n/a","id":"CVE-2012-2376","kev_date_added":null,"published":"2012-05-21"},{"cvss_score":10,"headline":"Memory corruption in n/a","id":"CVE-2011-3268","kev_date_added":null,"published":"2011-08-25"},{"cvss_score":10,"headline":"Other in n/a","id":"CVE-2009-4143","kev_date_added":null,"published":"2009-12-21"},{"cvss_score":10,"headline":"Memory corruption in n/a","id":"CVE-2008-5557","kev_date_added":null,"published":"2008-12-23"},{"cvss_score":10,"headline":"Memory corruption in n/a","id":"CVE-2008-2050","kev_date_added":null,"published":"2008-05-05"},{"cvss_score":10,"headline":"Command injection in n/a","id":"CVE-2008-2051","kev_date_added":null,"published":"2008-05-05"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"SUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"A buffer over-read in PHP's unserializer allows attackers to cause integrity issues or crashes when processing untrusted data.","url":"https://insights.sbomify.com/CVE-2017-12933/"}