# CVE-2017-12973: Nimbus JOSE+JWT vulnerable to padding oracle attack

> Attackers can exploit a padding oracle vulnerability in Nimbus JOSE+JWT to decrypt AES-CBC data by improperly handling invalid HMACs.

- **Severity:** Low 3.1 (`CVSS:3.0/AV:N/AC:H/PR:N/UI:R/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 20 Aug 2017
- **Updated:** 17 Sep 2024
- **Also known as:** GHSA-jfmq-4g4m-99rh

## What is CVE-2017-12973?

CVE-2017-12973 is a low-severity vulnerability in n/a, published on 20 Aug 2017. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Nimbus JOSE+JWT before 4.39 proceeds improperly after detection of an invalid HMAC in authenticated AES-CBC decryption, which allows attackers to conduct a padding oracle attack.

Weakness: CWE-354 (Improper Validation of Integrity Check Value)

## Which versions are affected by CVE-2017-12973?

2 open source packages ship an affected version, including com.nimbusds:nimbus-jose-jwt. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `com.nimbusds:nimbus-jose-jwt` | Maven | All versions | 4.39 |
| `com.nimbusds:nimbus-jose-jwt` | Maven | All versions | 4.39 |

Products: Connect2id Nimbus Jose\+jwt.

## How do I fix CVE-2017-12973?

Upgrade com.nimbusds:nimbus-jose-jwt to 4.39 or later.

## Is CVE-2017-12973 being exploited?

There is no known exploitation of CVE-2017-12973 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2023-52428](https://insights.sbomify.com/CVE-2023-52428/): Denial of Service in Connect2id Nimbus JOSE+JWT (high 7.5)
- [CVE-2017-12972](https://insights.sbomify.com/CVE-2017-12972/): Nimbus JOSE+JWT missing overflow check (high 7.5)
- [CVE-2017-12974](https://insights.sbomify.com/CVE-2017-12974/): Improper Verification of Cryptographic Signature in Nimbus JOSE+JWT (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-12973 and fix it if it is affected.

What it is: CVE-2017-12973 is a low-severity vulnerability in n/a, published on 20 Aug 2017. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2017-12973 in the wild and no public exploit code.

Affected packages and fixed versions:
- com.nimbusds:nimbus-jose-jwt (Maven): affected all versions; fixed in 4.39
- com.nimbusds:nimbus-jose-jwt (Maven): affected all versions; fixed in 4.39

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-12973/ (Markdown: https://insights.sbomify.com/CVE-2017-12973/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-12973
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-12973
- OSV: https://osv.dev/vulnerability/CVE-2017-12973

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-12973/
Summaries are generated and may contain mistakes; the official description above is the record.
