{"answers":{"affected":"2 open source packages ship an affected version, including com.nimbusds:nimbus-jose-jwt. It affects 1 product.","exploited":"There is no known exploitation of CVE-2017-12974 in the wild and no public exploit code.","fix":"Upgrade com.nimbusds:nimbus-jose-jwt to 4.36 or later.","what":"CVE-2017-12974 is a high-severity vulnerability in n/a, published on 20 Aug 2017. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2017-12974 and fix it if it is affected.\n\nWhat it is: CVE-2017-12974 is a high-severity vulnerability in n/a, published on 20 Aug 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2017-12974 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- com.nimbusds:nimbus-jose-jwt (Maven): affected all versions; fixed in 4.36\n- com.nimbusds:nimbus-jose-jwt (Maven): affected all versions; fixed in 4.36\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2017-12974/ (Markdown: https://insights.sbomify.com/CVE-2017-12974/index.md)","id":"CVE-2017-12974","markdown":"https://insights.sbomify.com/CVE-2017-12974/index.md","name":"CVE-2017-12974","record":{"aliases":["GHSA-pfv2-37f7-9m6w"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":true,"product_category":"Java JWT library","requires_auth":"none","summary":"Attackers can bypass cryptographic validation in Nimbus JOSE+JWT by exploiting invalid curve attacks when the underlying JCE provider lacks curve validation.","user_interaction":"not_required","vuln_class":"other"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"nimbus_jose\\+jwt","vendor":"connect2id"}],"cvss":{"score":7.5,"severity":"high","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N","version":"3.0"},"cwes":[{"id":"CWE-347","name":"Improper Verification of Cryptographic Signature"}],"description":"Nimbus JOSE+JWT before 4.36 proceeds with ECKey construction without ensuring that the public x and y coordinates are on the specified curve, which allows attackers to conduct an Invalid Curve Attack in environments where the JCE provider lacks the applicable curve validation.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Improper Verification of Cryptographic Signature in Nimbus JOSE+JWT","id":"CVE-2017-12974","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"other","year":"2017"},"n_packages":2,"n_references":4,"next":{"headline":"Command injection in n/a","id":"CVE-2017-12976"},"packages":[{"ecosystem":"Maven","fixed":["4.36"],"introduced":["0"],"last_affected":[],"package":"com.nimbusds:nimbus-jose-jwt","purl":null,"source":"GHSA-pfv2-37f7-9m6w"},{"ecosystem":"Maven","fixed":["4.36"],"introduced":["0"],"last_affected":[],"package":"com.nimbusds:nimbus-jose-jwt","purl":"pkg:maven/com.nimbusds/nimbus-jose-jwt","source":"GHSA-pfv2-37f7-9m6w"}],"prev":{"headline":"Nimbus JOSE+JWT vulnerable to padding oracle attack","id":"CVE-2017-12973"},"products":["n/a"],"published":"2017-08-20","related":[{"cvss_score":7.5,"headline":"Denial of Service in Connect2id Nimbus JOSE+JWT","id":"CVE-2023-52428","kev_date_added":null,"published":"2024-02-11"},{"cvss_score":7.5,"headline":"Nimbus JOSE+JWT missing overflow check","id":"CVE-2017-12972","kev_date_added":null,"published":"2017-08-20"},{"cvss_score":3.1,"headline":"Nimbus JOSE+JWT vulnerable to padding oracle attack","id":"CVE-2017-12973","kev_date_added":null,"published":"2017-08-20"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"Attackers can bypass cryptographic validation in Nimbus JOSE+JWT by exploiting invalid curve attacks when the underlying JCE provider lacks curve validation.","url":"https://insights.sbomify.com/CVE-2017-12974/"}