# CVE-2017-12976: Command injection in n/a

> Remote attackers can execute arbitrary commands in git-annex via crafted SSH URLs with dash-prefixed hostnames, requiring an upgrade to secure the tool.

- **Severity:** High 8.8 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 20 Aug 2017
- **Updated:** 5 Aug 2024
- **Also known as:** DEBIAN-CVE-2017-12976, DLA-1144-1, DSA-4010-1, GHSA-jqcx-qqvc-9wx5, HSEC-2023-0009, UBUNTU-CVE-2017-12976

## What is CVE-2017-12976?

CVE-2017-12976 is a high-severity command injection vulnerability in n/a, published on 20 Aug 2017. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

git-annex before 6.20170818 allows remote attackers to execute arbitrary commands via an ssh URL with an initial dash character in the hostname, as demonstrated by an ssh://-eProxyCommand= URL, a related issue to CVE-2017-9800, CVE-2017-12836, CVE-2017-1000116, and CVE-2017-1000117.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2017-12976?

1 open source package ship an affected version, including git-annex. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `git-annex` | Hackage | All versions | 6.20170818 |

Products: Git-Annex Project Git-Annex.

## How do I fix CVE-2017-12976?

Upgrade git-annex to 6.20170818 or later.

## Is CVE-2017-12976 being exploited?

There is no known exploitation of CVE-2017-12976 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2014-6274](https://insights.sbomify.com/CVE-2014-6274/): S3 and Glacier remotes creds embedded in the git repo were not encrypted (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-12976 and fix it if it is affected.

What it is: CVE-2017-12976 is a high-severity command injection vulnerability in n/a, published on 20 Aug 2017. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2017-12976 in the wild and no public exploit code.

Affected packages and fixed versions:
- git-annex (Hackage): affected all versions; fixed in 6.20170818

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-12976/ (Markdown: https://insights.sbomify.com/CVE-2017-12976/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-12976
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-12976
- OSV: https://osv.dev/vulnerability/CVE-2017-12976

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-12976/
Summaries are generated and may contain mistakes; the official description above is the record.
