# CVE-2017-13761: Fastly Magento2 sensitive information disclosure

> Authenticated users can obtain sensitive session information via cached redirect responses in the Fastly CDN module for Magento2.

- **Severity:** Medium 6.5 (`CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 14 Sep 2017
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-vpq9-c67q-23fq

## What is CVE-2017-13761?

CVE-2017-13761 is a medium-severity vulnerability in n/a, published on 14 Sep 2017. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

The Fastly CDN module before 1.2.26 for Magento2, when used with a third-party authentication plugin, might allow remote authenticated users to obtain sensitive information from authenticated sessions via vectors involving caching of redirect responses.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2017-13761?

2 open source packages ship an affected version, including fastly/magento2. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `fastly/magento2` | Packagist | All versions | 1.2.26 |
| `fastly/magento2` | Packagist | All versions | 1.2.26 |

Products: Fastly Fastly.

## How do I fix CVE-2017-13761?

Upgrade fastly/magento2 to 1.2.26 or later.

## Is CVE-2017-13761 being exploited?

There is no known exploitation of CVE-2017-13761 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2015-10094](https://insights.sbomify.com/CVE-2015-10094/): Fastly Plugin api.php post cross site scripting (low 2.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-13761 and fix it if it is affected.

What it is: CVE-2017-13761 is a medium-severity vulnerability in n/a, published on 14 Sep 2017. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2017-13761 in the wild and no public exploit code.

Affected packages and fixed versions:
- fastly/magento2 (Packagist): affected all versions; fixed in 1.2.26
- fastly/magento2 (Packagist): affected all versions; fixed in 1.2.26

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-13761/ (Markdown: https://insights.sbomify.com/CVE-2017-13761/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-13761
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-13761
- OSV: https://osv.dev/vulnerability/CVE-2017-13761

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-13761/
Summaries are generated and may contain mistakes; the official description above is the record.
