# CVE-2017-14033: Ruby OpenSSL DoS Vulnerability

> Attackers can cause a denial of service via interpreter crash by sending crafted strings to the Ruby OpenSSL ASN1 decode method.

- **Severity:** High 7.5 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 19 Sep 2017
- **Updated:** 5 Aug 2024
- **Also known as:** ALPINE-CVE-2017-14033, CLEANSTART-2026-PG57442, GHSA-v6rp-3r3v-hf4p, UBUNTU-CVE-2017-14033

## What is CVE-2017-14033?

CVE-2017-14033 is a high-severity denial of service vulnerability in Ruby-Lang Ruby, published on 19 Sep 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The decode method in the OpenSSL::ASN1 module in Ruby before 2.2.8, 2.3.x before 2.3.5, and 2.4.x through 2.4.1 allows attackers to cause a denial of service (interpreter crash) via a crafted string.

Weakness: CWE-119 (Improper Restriction of Operations within the Bounds of a Memory Buffer)

## Which versions are affected by CVE-2017-14033?

2 open source packages ship an affected version, including openssl. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `openssl` | RubyGems | All versions | 2.0.0 |
| `openssl` | RubyGems | All versions | 2.0.0 |

Products: Ruby-Lang Ruby.

## How do I fix CVE-2017-14033?

Upgrade openssl to 2.0.0 or later.

## Is CVE-2017-14033 being exploited?

There is no known exploitation of CVE-2017-14033 in the wild and no public exploit code.

## Other vulnerabilities in Ruby-Lang Ruby

- [CVE-2009-4124](https://insights.sbomify.com/CVE-2009-4124/): Memory corruption in n/a (critical 10.0)
- [CVE-2022-28738](https://insights.sbomify.com/CVE-2022-28738/): Use after free in n/a (critical 9.8)
- [CVE-2011-4121](https://insights.sbomify.com/CVE-2011-4121/): Weak cryptography in OpenSSL extension of Ruby (Git trunk) (critical 9.8)
- [CVE-2017-17790](https://insights.sbomify.com/CVE-2017-17790/): Command injection in n/a (critical 9.8)
- [CVE-2017-11465](https://insights.sbomify.com/CVE-2017-11465/): Memory corruption in n/a (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-14033 and fix it if it is affected.

What it is: CVE-2017-14033 is a high-severity denial of service vulnerability in Ruby-Lang Ruby, published on 19 Sep 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2017-14033 in the wild and no public exploit code.

Affected packages and fixed versions:
- openssl (RubyGems): affected all versions; fixed in 2.0.0
- openssl (RubyGems): affected all versions; fixed in 2.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-14033/ (Markdown: https://insights.sbomify.com/CVE-2017-14033/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-14033
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-14033
- OSV: https://osv.dev/vulnerability/CVE-2017-14033

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-14033/
Summaries are generated and may contain mistakes; the official description above is the record.
