{"answers":{"affected":"It affects 2 products.","exploited":"There is no known exploitation of CVE-2017-14062 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2017-14062 is a critical vulnerability in Debian Debian Linux, published on 31 Aug 2017. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2017-14062 and fix it if it is affected.\n\nWhat it is: CVE-2017-14062 is a critical vulnerability in Debian Debian Linux, published on 31 Aug 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2017-14062 in the wild and no public exploit code.\n\nAffected product: Debian Debian Linux. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2017-14062/ (Markdown: https://insights.sbomify.com/CVE-2017-14062/index.md)","id":"CVE-2017-14062","markdown":"https://insights.sbomify.com/CVE-2017-14062/index.md","name":"CVE-2017-14062","record":{"aliases":["DEBIAN-CVE-2017-14062","DLA-1084-1","DLA-1085-1","DLA-1447-1","DSA-3988-1","GHSA-783h-w6p2-278g","MGASA-2017-0365","SUSE-SU-2018:0878-1","SUSE-SU-2018:0903-1","UBUNTU-CVE-2017-14062","USN-3421-2","USN-3434-1","openSUSE-SU-2024:10949-1"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Libidn2 library","requires_auth":"none","summary":"Remote attackers can cause a denial of service via an integer overflow in the Libidn2 library's punycode decoding function.","user_interaction":"not_required","vuln_class":"integer_overflow"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"debian_linux","vendor":"debian"},{"product":"libidn2","vendor":"gnu"}],"cvss":{"score":9.8,"severity":"critical","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-190","name":"Integer Overflow or Wraparound"}],"description":"Integer overflow in the decode_digit function in puny_decode.c in Libidn2 before 2.0.4 allows remote attackers to cause a denial of service or possibly have unspecified other impact.","ecosystems":["SUSE:Linux Enterprise Desktop 12 SP3","SUSE:Linux Enterprise Server 11 SP4","SUSE:Linux Enterprise Server 12 SP3","SUSE:Linux Enterprise Server for SAP Applications 11 SP4","SUSE:Linux Enterprise Server for SAP Applications 12 SP3","SUSE:Linux Enterprise Software Development Kit 11 SP4","SUSE:Linux Enterprise Software Development Kit 12 SP3"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Integer overflow in n/a","id":"CVE-2017-14062","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":"debian:debian_linux","products":["debian:debian_linux"],"type":"integer_overflow","year":"2017"},"n_packages":7,"n_references":4,"next":{"headline":"Improper Input Validation in async-http-client","id":"CVE-2017-14063"},"packages":[{"ecosystem":"SUSE:Linux Enterprise Desktop 12 SP3","fixed":["1.28-5.3.1"],"introduced":["0"],"last_affected":[],"package":"libidn","purl":"pkg:rpm/suse/libidn\u0026distro=SUSE%20Linux%20Enterprise%20Desktop%2012%20SP3","source":"SUSE-SU-2018:0878-1"},{"ecosystem":"SUSE:Linux Enterprise Server 11 SP4","fixed":["1.10-7.3.1"],"introduced":["0"],"last_affected":[],"package":"libidn","purl":"pkg:rpm/suse/libidn\u0026distro=SUSE%20Linux%20Enterprise%20Server%2011%20SP4","source":"SUSE-SU-2018:0903-1"},{"ecosystem":"SUSE:Linux Enterprise Server 12 SP3","fixed":["1.28-5.3.1"],"introduced":["0"],"last_affected":[],"package":"libidn","purl":"pkg:rpm/suse/libidn\u0026distro=SUSE%20Linux%20Enterprise%20Server%2012%20SP3","source":"SUSE-SU-2018:0878-1"},{"ecosystem":"SUSE:Linux Enterprise Server for SAP Applications 11 SP4","fixed":["1.10-7.3.1"],"introduced":["0"],"last_affected":[],"package":"libidn","purl":"pkg:rpm/suse/libidn\u0026distro=SUSE%20Linux%20Enterprise%20Server%20for%20SAP%20Applications%2011%20SP4","source":"SUSE-SU-2018:0903-1"},{"ecosystem":"SUSE:Linux Enterprise Server for SAP Applications 12 SP3","fixed":["1.28-5.3.1"],"introduced":["0"],"last_affected":[],"package":"libidn","purl":"pkg:rpm/suse/libidn\u0026distro=SUSE%20Linux%20Enterprise%20Server%20for%20SAP%20Applications%2012%20SP3","source":"SUSE-SU-2018:0878-1"},{"ecosystem":"SUSE:Linux Enterprise Software Development Kit 11 SP4","fixed":["1.10-7.3.1"],"introduced":["0"],"last_affected":[],"package":"libidn","purl":"pkg:rpm/suse/libidn\u0026distro=SUSE%20Linux%20Enterprise%20Software%20Development%20Kit%2011%20SP4","source":"SUSE-SU-2018:0903-1"},{"ecosystem":"SUSE:Linux Enterprise Software Development Kit 12 SP3","fixed":["1.28-5.3.1"],"introduced":["0"],"last_affected":[],"package":"libidn","purl":"pkg:rpm/suse/libidn\u0026distro=SUSE%20Linux%20Enterprise%20Software%20Development%20Kit%2012%20SP3","source":"SUSE-SU-2018:0878-1"}],"prev":{"headline":"Integer overflow in n/a","id":"CVE-2017-14061"},"products":["n/a"],"published":"2017-08-31","related":[{"cvss_score":10,"headline":"ProFTPD Improper Access Control","id":"CVE-2015-3306","kev_date_added":"2026-10-08","published":"2015-05-18"},{"cvss_score":9.9,"headline":"RoundCube Webmail Deserialization of Untrusted Data","id":"CVE-2025-49113","kev_date_added":"2026-02-20","published":"2025-06-02"},{"cvss_score":9.8,"headline":"GNU InetUtils Argument Injection","id":"CVE-2026-24061","kev_date_added":"2026-01-26","published":"2026-01-21"},{"cvss_score":9.8,"headline":"Linux Kernel Improper Check for Unusual or Exceptional Conditions","id":"CVE-2025-39682","kev_date_added":"2026-09-18","published":"2025-09-05"},{"cvss_score":9.8,"headline":"Mozilla Firefox Use-After-Free","id":"CVE-2024-9680","kev_date_added":"2024-10-15","published":"2024-10-09"},{"cvss_score":9.8,"headline":"RARLAB UnRAR Directory Traversal","id":"CVE-2022-30333","kev_date_added":"2022-08-09","published":"2022-05-09"},{"cvss_score":9.8,"headline":"Roundcube Webmail SQL Injection","id":"CVE-2021-44026","kev_date_added":"2023-06-22","published":"2021-11-19"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"SUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"Remote attackers can cause a denial of service via an integer overflow in the Libidn2 library's punycode decoding function.","url":"https://insights.sbomify.com/CVE-2017-14062/"}