# CVE-2017-14063: Improper Input Validation in async-http-client

> Attackers can trick the Async Http Client into connecting to an unintended host via fragment identifiers, bypassing SSRF protections.

- **Severity:** High 7.5 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 31 Aug 2017
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-93jq-624g-4p9p

## What is CVE-2017-14063?

CVE-2017-14063 is a high-severity server-side request forgery vulnerability in n/a, published on 31 Aug 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Async Http Client (aka async-http-client) before 2.0.35 can be tricked into connecting to a host different from the one extracted by java.net.URI if a '?' character occurs in a fragment identifier. Similar bugs were previously identified in cURL (CVE-2016-8624) and Oracle Java 8 java.net.URL.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2017-14063?

2 open source packages ship an affected version, including org.asynchttpclient:async-http-client. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.asynchttpclient:async-http-client` | Maven | All versions | 2.0.35 |
| `org.asynchttpclient:async-http-client` | Maven | All versions | 2.0.35 |

Products: Asynchttpclient Project Async-Http-Client.

## How do I fix CVE-2017-14063?

Upgrade org.asynchttpclient:async-http-client to 2.0.35 or later.

## Is CVE-2017-14063 being exploited?

There is no known exploitation of CVE-2017-14063 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2023-0040](https://insights.sbomify.com/CVE-2023-0040/): Async HTTP Client has CRLF Injection vulnerability in HTTP request headers (high 7.5)
- [CVE-2026-45300](https://insights.sbomify.com/CVE-2026-45300/): async-http-client: Cookie header not stripped on cross-origin redirect (high 7.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-14063 and fix it if it is affected.

What it is: CVE-2017-14063 is a high-severity server-side request forgery vulnerability in n/a, published on 31 Aug 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2017-14063 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.asynchttpclient:async-http-client (Maven): affected all versions; fixed in 2.0.35
- org.asynchttpclient:async-http-client (Maven): affected all versions; fixed in 2.0.35

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-14063/ (Markdown: https://insights.sbomify.com/CVE-2017-14063/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-14063
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-14063
- OSV: https://osv.dev/vulnerability/CVE-2017-14063

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-14063/
Summaries are generated and may contain mistakes; the official description above is the record.
