{"answers":{"affected":"It affects 2 products.","exploited":"There is no known exploitation of CVE-2017-14226 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2017-14226 is a high-severity memory corruption vulnerability in Libreoffice Libreoffice, published on 9 Sep 2017. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2017-14226 and fix it if it is affected.\n\nWhat it is: CVE-2017-14226 is a high-severity memory corruption vulnerability in Libreoffice Libreoffice, published on 9 Sep 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2017-14226 in the wild and no public exploit code.\n\nAffected product: Libreoffice Libreoffice. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2017-14226/ (Markdown: https://insights.sbomify.com/CVE-2017-14226/index.md)","id":"CVE-2017-14226","markdown":"https://insights.sbomify.com/CVE-2017-14226/index.md","name":"CVE-2017-14226","record":{"aliases":["DEBIAN-CVE-2017-14226","GHSA-4m96-cjx2-px9q","MGASA-2017-0358","SUSE-SU-2017:2931-1","UBUNTU-CVE-2017-14226"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"libwpd library","requires_auth":"none","summary":"Remote attackers can cause a denial of service via heap-based buffer over-read in libwpd, affecting LibreOffice users.","user_interaction":"not_required","vuln_class":"memory_corruption"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"libreoffice","vendor":"libreoffice"},{"product":"libwpd","vendor":"libwpd"}],"cvss":{"score":7.5,"severity":"high","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-125","name":"Out-of-bounds Read"}],"description":"WP1StylesListener.cpp, WP5StylesListener.cpp, and WP42StylesListener.cpp in libwpd 0.10.1 mishandle iterators, which allows remote attackers to cause a denial of service (heap-based buffer over-read in the WPXTableList class in WPXTable.cpp). This vulnerability can be triggered in LibreOffice before 5.3.7. It may lead to suffering a remote attack against a LibreOffice application.","ecosystems":["SUSE:Linux Enterprise Desktop 12 SP2","SUSE:Linux Enterprise Desktop 12 SP3","SUSE:Linux Enterprise Software Development Kit 12 SP2","SUSE:Linux Enterprise Software Development Kit 12 SP3","SUSE:Linux Enterprise Workstation Extension 12 SP2","SUSE:Linux Enterprise Workstation Extension 12 SP3"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Memory corruption in n/a","id":"CVE-2017-14226","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":"libreoffice:libreoffice","products":["libreoffice:libreoffice"],"type":"memory_corruption","year":"2017"},"n_packages":6,"n_references":6,"next":{"headline":"Memory corruption in n/a","id":"CVE-2017-14227"},"packages":[{"ecosystem":"SUSE:Linux Enterprise Desktop 12 SP2","fixed":["0.10.2-2.4.1"],"introduced":["0"],"last_affected":[],"package":"libwpd","purl":"pkg:rpm/suse/libwpd\u0026distro=SUSE%20Linux%20Enterprise%20Desktop%2012%20SP2","source":"SUSE-SU-2017:2931-1"},{"ecosystem":"SUSE:Linux Enterprise Desktop 12 SP3","fixed":["0.10.2-2.4.1"],"introduced":["0"],"last_affected":[],"package":"libwpd","purl":"pkg:rpm/suse/libwpd\u0026distro=SUSE%20Linux%20Enterprise%20Desktop%2012%20SP3","source":"SUSE-SU-2017:2931-1"},{"ecosystem":"SUSE:Linux Enterprise Software Development Kit 12 SP2","fixed":["0.10.2-2.4.1"],"introduced":["0"],"last_affected":[],"package":"libwpd","purl":"pkg:rpm/suse/libwpd\u0026distro=SUSE%20Linux%20Enterprise%20Software%20Development%20Kit%2012%20SP2","source":"SUSE-SU-2017:2931-1"},{"ecosystem":"SUSE:Linux Enterprise Software Development Kit 12 SP3","fixed":["0.10.2-2.4.1"],"introduced":["0"],"last_affected":[],"package":"libwpd","purl":"pkg:rpm/suse/libwpd\u0026distro=SUSE%20Linux%20Enterprise%20Software%20Development%20Kit%2012%20SP3","source":"SUSE-SU-2017:2931-1"},{"ecosystem":"SUSE:Linux Enterprise Workstation Extension 12 SP2","fixed":["0.10.2-2.4.1"],"introduced":["0"],"last_affected":[],"package":"libwpd","purl":"pkg:rpm/suse/libwpd\u0026distro=SUSE%20Linux%20Enterprise%20Workstation%20Extension%2012%20SP2","source":"SUSE-SU-2017:2931-1"},{"ecosystem":"SUSE:Linux Enterprise Workstation Extension 12 SP3","fixed":["0.10.2-2.4.1"],"introduced":["0"],"last_affected":[],"package":"libwpd","purl":"pkg:rpm/suse/libwpd\u0026distro=SUSE%20Linux%20Enterprise%20Workstation%20Extension%2012%20SP3","source":"SUSE-SU-2017:2931-1"}],"prev":{"headline":"Null dereference in n/a","id":"CVE-2017-14225"},"products":["n/a"],"published":"2017-09-09","related":[{"cvss_score":10,"headline":"TLS certificate are not properly verified when utilizing LibreOfficeKit","id":"CVE-2024-5261","kev_date_added":null,"published":"2024-06-25"},{"cvss_score":9.8,"headline":"Windows 8.3 path equivalence handling flaw allows LibreLogo script execution","id":"CVE-2019-9855","kev_date_added":null,"published":"2019-09-06"},{"cvss_score":9.8,"headline":"Memory corruption in n/a","id":"CVE-2018-14939","kev_date_added":null,"published":"2018-08-05"},{"cvss_score":9.8,"headline":"Memory corruption in n/a","id":"CVE-2017-8358","kev_date_added":null,"published":"2017-04-30"},{"cvss_score":9.8,"headline":"Memory corruption in n/a","id":"CVE-2017-7882","kev_date_added":null,"published":"2017-04-15"},{"cvss_score":9.8,"headline":"Memory corruption in n/a","id":"CVE-2016-10327","kev_date_added":null,"published":"2017-04-14"},{"cvss_score":9.8,"headline":"Memory corruption in n/a","id":"CVE-2017-7856","kev_date_added":null,"published":"2017-04-14"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"SUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-16","vendors":["n/a"]},"summary":"Remote attackers can cause a denial of service via heap-based buffer over-read in libwpd, affecting LibreOffice users.","url":"https://insights.sbomify.com/CVE-2017-14226/"}