# CVE-2017-14239: Dolibarr cross-site scripting (XSS) vulnerability

> Authenticated attackers can inject arbitrary scripts via company profile fields in Dolibarr, potentially leading to session hijacking or malicious actions.

- **Severity:** Medium 5.4 (`CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 11 Sep 2017
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-74c7-r9m3-hvj4, UBUNTU-CVE-2017-14239

## What is CVE-2017-14239?

CVE-2017-14239 is a medium-severity cross-site scripting vulnerability in n/a, published on 11 Sep 2017. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Multiple cross-site scripting (XSS) vulnerabilities in Dolibarr ERP/CRM 6.0.0 allow remote authenticated users to inject arbitrary web script or HTML via the (1) CompanyName, (2) CompanyAddress, (3) CompanyZip, (4) CompanyTown, (5) Fax, (6) EMail, (7) Web, (8) ManagingDirectors, (9) Note, (10) Capital, (11) ProfId1, (12) ProfId2, (13) ProfId3, (14) ProfId4, (15) ProfId5, or (16) ProfId6 parameter to htdocs/admin/company.php.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2017-14239?

2 open source packages ship an affected version, including dolibarr/dolibarr. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `dolibarr/dolibarr` | Packagist | From 6.0.0 | 6.0.1 |
| `dolibarr/dolibarr` | Packagist | From 6.0.0 | 6.0.1 |

Products: Dolibarr Dolibarr.

## How do I fix CVE-2017-14239?

Upgrade dolibarr/dolibarr to 6.0.1 or later.

## Is CVE-2017-14239 being exploited?

There is no known exploitation of CVE-2017-14239 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2019-19212](https://insights.sbomify.com/CVE-2019-19212/): Dolibarr Cross-site Scripting via the qty parameter in product/fournisseurs.php (critical 9.8)
- [CVE-2018-16809](https://insights.sbomify.com/CVE-2018-16809/): Dolibarr SQL injection via the integer parameters qty and value_unit (critical 9.8)
- [CVE-2018-10094](https://insights.sbomify.com/CVE-2018-10094/): Dolibarr SQL injection vulnerability (critical 9.8)
- [CVE-2018-9019](https://insights.sbomify.com/CVE-2018-9019/): Dolibarr SQL Injection vulnerability (critical 9.8)
- [CVE-2017-14238](https://insights.sbomify.com/CVE-2017-14238/): Dolibarr SQL injection vulnerability in admin/menus/edit.php (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-14239 and fix it if it is affected.

What it is: CVE-2017-14239 is a medium-severity cross-site scripting vulnerability in n/a, published on 11 Sep 2017. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2017-14239 in the wild and no public exploit code.

Affected packages and fixed versions:
- dolibarr/dolibarr (Packagist): affected from 6.0.0; fixed in 6.0.1
- dolibarr/dolibarr (Packagist): affected from 6.0.0; fixed in 6.0.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-14239/ (Markdown: https://insights.sbomify.com/CVE-2017-14239/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-14239
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-14239
- OSV: https://osv.dev/vulnerability/CVE-2017-14239

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-14239/
Summaries are generated and may contain mistakes; the official description above is the record.
