# CVE-2017-14498: Silverstripe CMS XSS Vulnerability

> Cross-site scripting vulnerability in SilverStripe CMS allows attackers to execute arbitrary scripts via malicious SVG uploads in the media editor.

- **Severity:** Medium 6.1 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 15 Sep 2017
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-j696-6m57-mcrv

## What is CVE-2017-14498?

CVE-2017-14498 is a medium-severity cross-site scripting vulnerability in Silverstripe Silverstripe, published on 15 Sep 2017. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

SilverStripe CMS before 3.6.1 has XSS via an SVG document that is mishandled by (1) the Insert Media option in the content editor or (2) an admin/assets/add pathname, as demonstrated by the admin/pages/edit/EditorToolbar/MediaForm/field/AssetUploadField/upload URI, aka issue SS-2017-017.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2017-14498?

2 open source packages ship an affected version, including silverstripe/cms. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `silverstripe/cms` | Packagist | All versions | 3.6.1 |
| `silverstripe/cms` | Packagist | All versions | 3.6.1 |

Products: Silverstripe Silverstripe.

## How do I fix CVE-2017-14498?

Upgrade silverstripe/cms to 3.6.1 or later.

## Is CVE-2017-14498 being exploited?

There is no known exploitation of CVE-2017-14498 in the wild and no public exploit code.

## Other vulnerabilities in Silverstripe Silverstripe

- [CVE-2007-2321](https://insights.sbomify.com/CVE-2007-2321/): Other in n/a (critical 10.0)
- [CVE-2019-12204](https://insights.sbomify.com/CVE-2019-12204/): Missing warning can lead to unauthenticated admin access in SilverStripe (critical 9.8)
- [CVE-2019-5715](https://insights.sbomify.com/CVE-2019-5715/): Silverstripe Framework SQLi Vulnerability (critical 9.8)
- [CVE-2019-12437](https://insights.sbomify.com/CVE-2019-12437/): Silverstripe CSRF Protection Bypass via GraphQL (high 8.8)
- [CVE-2020-6164](https://insights.sbomify.com/CVE-2020-6164/): Silverstripe CMS information disclosure (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-14498 and fix it if it is affected.

What it is: CVE-2017-14498 is a medium-severity cross-site scripting vulnerability in Silverstripe Silverstripe, published on 15 Sep 2017. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2017-14498 in the wild and no public exploit code.

Affected packages and fixed versions:
- silverstripe/cms (Packagist): affected all versions; fixed in 3.6.1
- silverstripe/cms (Packagist): affected all versions; fixed in 3.6.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-14498/ (Markdown: https://insights.sbomify.com/CVE-2017-14498/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-14498
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-14498
- OSV: https://osv.dev/vulnerability/CVE-2017-14498

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-14498/
Summaries are generated and may contain mistakes; the official description above is the record.
