# CVE-2017-14506: Gem in a Box vulnerable to Cross-site Scripting

> Cross-site scripting vulnerability in Gem in a Box allows attackers to execute arbitrary scripts via crafted gem metadata.

- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 25 Sep 2017
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-98hq-3qvg-pg78

## What is CVE-2017-14506?

CVE-2017-14506 is a medium-severity cross-site scripting vulnerability in n/a, published on 25 Sep 2017. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

geminabox (aka Gem in a Box) before 0.13.6 has XSS, as demonstrated by uploading a gem file that has a crafted gem.homepage value in its .gemspec file.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2017-14506?

2 open source packages ship an affected version, including geminabox. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `geminabox` | RubyGems | All versions | 0.13.6 |
| `geminabox` | RubyGems | All versions | 0.13.6 |

Products: Geminabox Project Geminabox.

## How do I fix CVE-2017-14506?

Upgrade geminabox to 0.13.6 or later.

## Is CVE-2017-14506 being exploited?

There is no known exploitation of CVE-2017-14506 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2017-14683](https://insights.sbomify.com/CVE-2017-14683/): Gem in a Box vulnerable to Cross-site Request Forgery (high 8.8)
- [CVE-2017-16792](https://insights.sbomify.com/CVE-2017-16792/): Geminabox contains Cross-site Scripting (medium 6.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-14506 and fix it if it is affected.

What it is: CVE-2017-14506 is a medium-severity cross-site scripting vulnerability in n/a, published on 25 Sep 2017. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2017-14506 in the wild and no public exploit code.

Affected packages and fixed versions:
- geminabox (RubyGems): affected all versions; fixed in 0.13.6
- geminabox (RubyGems): affected all versions; fixed in 0.13.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-14506/ (Markdown: https://insights.sbomify.com/CVE-2017-14506/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-14506
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-14506
- OSV: https://osv.dev/vulnerability/CVE-2017-14506

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-14506/
Summaries are generated and may contain mistakes; the official description above is the record.
