CVE-2017-14589 Code injection in Bamboo

Critical 9.6 Published Updated

An attacker with restricted admin rights or via a malicious site can execute arbitrary Java code on Atlassian Bamboo servers.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
None listed

What is CVE-2017-14589?

CVE-2017-14589 is a critical code injection vulnerability in Atlassian Bamboo, published on 13 Dec 2017. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

It was possible for double OGNL evaluation in FreeMarker templates through Struts FreeMarker tags to occur. An attacker who has restricted administration rights to Bamboo or who hosts a website that a Bamboo administrator visits, is able to exploit this vulnerability to execute Java code of their choice on systems that run a vulnerable version of Bamboo. All versions of Bamboo before 6.1.6 (the fixed version for 6.1.x) and from 6.2.0 before 6.2.5 (the fixed version for 6.2.x) are affected by this vulnerability.

Weakness: CWE-20

Which versions are affected by CVE-2017-14589?

It affects 1 product.

Products include Atlassian Bamboo.

How do I fix CVE-2017-14589?

No fix has been published for CVE-2017-14589 yet. Limit exposure of the affected software until one is available.

Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.

Is CVE-2017-14589 being exploited?

There is no known exploitation of CVE-2017-14589 in the wild and no public exploit code.

Sources

Also known as GHSA-5375-qw4c-whr2.

Is CVE-2017-14589 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free