CVE-2017-14590 Command injection in Bamboo
An attacker with specific repository permissions can execute arbitrary code on the Bamboo server by injecting arguments into Mercurial branch names.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- None listed
What is CVE-2017-14590?
CVE-2017-14590 is a critical command injection vulnerability in Atlassian Bamboo, published on 13 Dec 2017. An attacker needs administrator access to exploit it, with no action from the victim.
Official description
Bamboo did not check that the name of a branch in a Mercurial repository contained argument parameters. An attacker who has permission to create a repository in Bamboo, edit an existing plan that has a non-linked Mercurialrepository, create or edit a plan when there is at least one linked Mercurial repository that the attacker has permission to use, or commit to a Mercurial repository used by a Bamboo plan which has branch detection enabled can execute code of their choice on systems that run a vulnerable version of Bamboo Server. Versions of Bamboo starting with 2.7.0 before 6.1.6 (the fixed version for 6.1.x) and from 6.2.0 before 6.2.5 (the fixed version for 6.2.x) are affected by this vulnerability.
Which versions are affected by CVE-2017-14590?
It affects 1 product.
Products include Atlassian Bamboo.
How do I fix CVE-2017-14590?
No fix has been published for CVE-2017-14590 yet. Limit exposure of the affected software until one is available.
Upgrade, and pass arguments to programs as a list instead of through a shell. More about Command injection.
Is CVE-2017-14590 being exploited?
There is no known exploitation of CVE-2017-14590 in the wild and no public exploit code.
Other vulnerabilities in Atlassian Bamboo
Sources
Also known as GHSA-6qp2-wv9g-xq2p.