# CVE-2017-14590: Command injection in Bamboo

> An attacker with specific repository permissions can execute arbitrary code on the Bamboo server by injecting arguments into Mercurial branch names.

- **Severity:** Critical 9.1 (`CVSS:3.0/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 13 Dec 2017
- **Updated:** 16 Sep 2024
- **Also known as:** GHSA-6qp2-wv9g-xq2p

## What is CVE-2017-14590?

CVE-2017-14590 is a critical command injection vulnerability in Atlassian Bamboo, published on 13 Dec 2017. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

Bamboo did not check that the name of a branch in a Mercurial repository contained argument parameters. An attacker who has permission to create a repository in Bamboo, edit an existing plan that has a non-linked Mercurialrepository, create or edit a plan when there is at least one linked Mercurial repository that the attacker has permission to use, or commit to a Mercurial repository used by a Bamboo plan which has branch detection enabled can execute code of their choice on systems that run a vulnerable version of Bamboo Server. Versions of Bamboo starting with 2.7.0 before 6.1.6 (the fixed version for 6.1.x) and from 6.2.0 before 6.2.5 (the fixed version for 6.2.x) are affected by this vulnerability.

## Which versions are affected by CVE-2017-14590?

It affects 1 product.


Products: Atlassian Bamboo.

## How do I fix CVE-2017-14590?

No fix has been published for CVE-2017-14590 yet. Limit exposure of the affected software until one is available.

## Is CVE-2017-14590 being exploited?

There is no known exploitation of CVE-2017-14590 in the wild and no public exploit code.

## Other vulnerabilities in Atlassian Bamboo

- [CVE-2026-21589](https://insights.sbomify.com/CVE-2026-21589/): Atlassian Multiple Products Files or Directories Accessible to External Parties (critical 9.3, exploited in the wild)
- [CVE-2022-26136](https://insights.sbomify.com/CVE-2022-26136/): Auth bypass in Bamboo Data Center (critical 9.8)
- [CVE-2016-5229](https://insights.sbomify.com/CVE-2016-5229/): Deserialization in n/a (critical 9.8)
- [CVE-2014-9757](https://insights.sbomify.com/CVE-2014-9757/): Deserialization in n/a (critical 9.8)
- [CVE-2015-8360](https://insights.sbomify.com/CVE-2015-8360/): Deserialization in n/a (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-14590 and fix it if it is affected.

What it is: CVE-2017-14590 is a critical command injection vulnerability in Atlassian Bamboo, published on 13 Dec 2017. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2017-14590 in the wild and no public exploit code.

Affected product: Atlassian Bamboo. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-14590/ (Markdown: https://insights.sbomify.com/CVE-2017-14590/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-14590
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-14590
- OSV: https://osv.dev/vulnerability/CVE-2017-14590

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-14590/
Summaries are generated and may contain mistakes; the official description above is the record.
