# CVE-2017-14696: SaltStack Salt Denial of Service via a crafted authentication request

> Remote attackers can cause a denial of service in SaltStack by sending a crafted authentication request, requiring an upgrade to patched versions.

- **Severity:** High 7.5 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 24 Oct 2017
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-657p-cj5r-mjrh, PYSEC-2017-37, UBUNTU-CVE-2017-14696

## What is CVE-2017-14696?

CVE-2017-14696 is a high-severity denial of service vulnerability in Saltstack Salt, published on 24 Oct 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

SaltStack Salt before 2016.3.8, 2016.11.x before 2016.11.8, and 2017.7.x before 2017.7.2 allows remote attackers to cause a denial of service via a crafted authentication request.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2017-14696?

7 open source packages ship an affected version, including salt. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `salt` | PyPI | All versions | 2016.3.8, 2016.11.8, 2017.7.2 |
| `salt` | PyPI | All versions | 2016.3.8 |
| `salt` | PyPI | All versions | 2016.3.8 |
| `salt` | PyPI | From 2016.11.0 | 2016.11.8 |
| `salt` | PyPI | From 2016.11.0 | 2016.11.8 |
| `salt` | PyPI | From 2017.7.0 | 2017.7.2 |
| `salt` | PyPI | From 2017.7.0 | 2017.7.2 |

Products: Saltstack Salt.

## How do I fix CVE-2017-14696?

Upgrade salt to a fixed version for your release line: 2016.3.8, 2016.11.8 or 2017.7.2.

## Is CVE-2017-14696 being exploited?

There is no known exploitation of CVE-2017-14696 in the wild and no public exploit code.

## Other vulnerabilities in Saltstack Salt

- [CVE-2013-4437](https://insights.sbomify.com/CVE-2013-4437/): SaltStack insecurely uses /tmp (critical 10.0)
- [CVE-2013-6617](https://insights.sbomify.com/CVE-2013-6617/): SaltStack Privilege Escalation vulnerability (critical 10.0)
- [CVE-2021-33226](https://insights.sbomify.com/CVE-2021-33226/): Code injection in n/a (critical 9.8)
- [CVE-2021-25315](https://insights.sbomify.com/CVE-2021-25315/): salt-api unauthenticated remote code execution (critical 9.8)
- [CVE-2018-15751](https://insights.sbomify.com/CVE-2018-15751/): SaltStack Salt Remote command execution and incorrect access control when using salt-api (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-14696 and fix it if it is affected.

What it is: CVE-2017-14696 is a high-severity denial of service vulnerability in Saltstack Salt, published on 24 Oct 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2017-14696 in the wild and no public exploit code.

Affected packages and fixed versions:
- salt (PyPI): affected all versions; fixed in 2016.3.8, 2016.11.8, 2017.7.2
- salt (PyPI): affected all versions; fixed in 2016.3.8
- salt (PyPI): affected all versions; fixed in 2016.3.8
- salt (PyPI): affected from 2016.11.0; fixed in 2016.11.8
- salt (PyPI): affected from 2016.11.0; fixed in 2016.11.8
- salt (PyPI): affected from 2017.7.0; fixed in 2017.7.2
- salt (PyPI): affected from 2017.7.0; fixed in 2017.7.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-14696/ (Markdown: https://insights.sbomify.com/CVE-2017-14696/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-14696
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-14696
- OSV: https://osv.dev/vulnerability/CVE-2017-14696

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-14696/
Summaries are generated and may contain mistakes; the official description above is the record.
