{"answers":{"affected":"2 open source packages ship an affected version, including org.owasp.antisamy:antisamy. It affects 1 product.","exploited":"There is no known exploitation of CVE-2017-14735 in the wild and no public exploit code.","fix":"Upgrade org.owasp.antisamy:antisamy to 1.5.7 or later.","what":"CVE-2017-14735 is a medium-severity cross-site scripting vulnerability in n/a, published on 25 Sep 2017. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2017-14735 and fix it if it is affected.\n\nWhat it is: CVE-2017-14735 is a medium-severity cross-site scripting vulnerability in n/a, published on 25 Sep 2017. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2017-14735 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.owasp.antisamy:antisamy (Maven): affected all versions; fixed in 1.5.7\n- org.owasp.antisamy:antisamy (Maven): affected all versions; fixed in 1.5.7\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2017-14735/ (Markdown: https://insights.sbomify.com/CVE-2017-14735/index.md)","id":"CVE-2017-14735","markdown":"https://insights.sbomify.com/CVE-2017-14735/index.md","name":"CVE-2017-14735","record":{"aliases":["DEBIAN-CVE-2017-14735","GHSA-q44v-xc3g-v7jq","UBUNTU-CVE-2017-14735"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Java HTML sanitizer","requires_auth":"none","summary":"An attacker can execute arbitrary JavaScript in a victim's browser by exploiting HTML5 entity handling in the AntiSamy library.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"antisamy","vendor":"antisamy_project"}],"cvss":{"score":6.1,"severity":"medium","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","version":"3.0"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"OWASP AntiSamy before 1.5.7 allows XSS via HTML5 entities, as demonstrated by use of \u0026colon; to construct a javascript: URL.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":"2025-08-20","github_poc":1,"max_poc_stars":0,"metasploit":0,"nuclei":0,"refs":[{"date":"2025-08-20T11:19:25Z","kind":"github_poc","ref":"https://github.com/shoucheng3/nahsra__antisamy_CVE-2017-14735_1-5-6","stars":0,"title":null}],"tier":"poc_unverified"},"has_fix":true,"headline":"OWASP AntiSamy Cross-site Scripting vulnerability","id":"CVE-2017-14735","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"xss","year":"2017"},"n_packages":2,"n_references":9,"next":{"headline":"Information disclosure in n/a","id":"CVE-2017-14737"},"packages":[{"ecosystem":"Maven","fixed":["1.5.7"],"introduced":["0"],"last_affected":[],"package":"org.owasp.antisamy:antisamy","purl":null,"source":"GHSA-q44v-xc3g-v7jq"},{"ecosystem":"Maven","fixed":["1.5.7"],"introduced":["0"],"last_affected":[],"package":"org.owasp.antisamy:antisamy","purl":"pkg:maven/org.owasp.antisamy/antisamy","source":"GHSA-q44v-xc3g-v7jq"}],"prev":{"headline":"Memory corruption in n/a","id":"CVE-2017-14734"},"products":["n/a"],"published":"2017-09-25","related":[{"cvss_score":7.5,"headline":"Denial of service in HtmlUnit-Neko","id":"CVE-2022-28366","kev_date_added":null,"published":"2022-04-21"},{"cvss_score":6.1,"headline":"AntiSamy malicious input can provoke XSS when preserving comments","id":"CVE-2024-23635","kev_date_added":null,"published":"2024-02-02"},{"cvss_score":6.1,"headline":"mXSS in AntiSamy","id":"CVE-2023-43643","kev_date_added":null,"published":"2023-10-09"},{"cvss_score":6.1,"headline":"Cross-site Scripting in OWASP AntiSamy","id":"CVE-2022-28367","kev_date_added":null,"published":"2022-04-21"},{"cvss_score":6.1,"headline":"Cross-site Scripting in OWASP AntiSamy","id":"CVE-2022-29577","kev_date_added":null,"published":"2022-04-21"},{"cvss_score":6.1,"headline":"Cross-site Scripting in OWASP AntiSamy","id":"CVE-2021-35043","kev_date_added":null,"published":"2021-07-19"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"open","licence":"CC0","name":"PoC-in-GitHub"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"An attacker can execute arbitrary JavaScript in a victim's browser by exploiting HTML5 entity handling in the AntiSamy library.","url":"https://insights.sbomify.com/CVE-2017-14735/"}