# CVE-2017-14735: OWASP AntiSamy Cross-site Scripting vulnerability

> An attacker can execute arbitrary JavaScript in a victim's browser by exploiting HTML5 entity handling in the AntiSamy library.

- **Severity:** Medium 6.1 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 25 Sep 2017
- **Updated:** 5 Aug 2024
- **Also known as:** DEBIAN-CVE-2017-14735, GHSA-q44v-xc3g-v7jq, UBUNTU-CVE-2017-14735

## What is CVE-2017-14735?

CVE-2017-14735 is a medium-severity cross-site scripting vulnerability in n/a, published on 25 Sep 2017. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

OWASP AntiSamy before 1.5.7 allows XSS via HTML5 entities, as demonstrated by use of &colon; to construct a javascript: URL.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2017-14735?

2 open source packages ship an affected version, including org.owasp.antisamy:antisamy. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.owasp.antisamy:antisamy` | Maven | All versions | 1.5.7 |
| `org.owasp.antisamy:antisamy` | Maven | All versions | 1.5.7 |

Products: Antisamy Project Antisamy.

## How do I fix CVE-2017-14735?

Upgrade org.owasp.antisamy:antisamy to 1.5.7 or later.

## Is CVE-2017-14735 being exploited?

There is no known exploitation of CVE-2017-14735 in the wild and no public exploit code.

Public exploit code:

- https://github.com/shoucheng3/nahsra__antisamy_CVE-2017-14735_1-5-6 (github_poc): https://github.com/shoucheng3/nahsra__antisamy_CVE-2017-14735_1-5-6

## Other vulnerabilities in n/a

- [CVE-2022-28366](https://insights.sbomify.com/CVE-2022-28366/): Denial of service in HtmlUnit-Neko (high 7.5)
- [CVE-2024-23635](https://insights.sbomify.com/CVE-2024-23635/): AntiSamy malicious input can provoke XSS when preserving comments (medium 6.1)
- [CVE-2023-43643](https://insights.sbomify.com/CVE-2023-43643/): mXSS in AntiSamy (medium 6.1)
- [CVE-2022-28367](https://insights.sbomify.com/CVE-2022-28367/): Cross-site Scripting in OWASP AntiSamy (medium 6.1)
- [CVE-2022-29577](https://insights.sbomify.com/CVE-2022-29577/): Cross-site Scripting in OWASP AntiSamy (medium 6.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-14735 and fix it if it is affected.

What it is: CVE-2017-14735 is a medium-severity cross-site scripting vulnerability in n/a, published on 25 Sep 2017. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2017-14735 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.owasp.antisamy:antisamy (Maven): affected all versions; fixed in 1.5.7
- org.owasp.antisamy:antisamy (Maven): affected all versions; fixed in 1.5.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-14735/ (Markdown: https://insights.sbomify.com/CVE-2017-14735/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-14735
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-14735
- OSV: https://osv.dev/vulnerability/CVE-2017-14735

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-14735/
Summaries are generated and may contain mistakes; the official description above is the record.
